PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Indique si un dictionnaire est disponible pour la vérification orthographique (vérification effectuée dans les champs utilisant la correction intégrée ou vérification par les fonctions WLangage). Ce dictionnaire peut être :
  • un dictionnaire Open Office.
  • Versions 24 et supérieures
    un dictionnaire Hunspell.
    Nouveauté 24
    un dictionnaire Hunspell.
    un dictionnaire Hunspell.
Exemple
SI OrthoDisponible() = Faux ALORS
Info("Le dictionnaire n'est pas installé")
FIN

SI OrthoDisponible() = Vrai ET OrthoVérifie(PASSWD) = Vrai ALORS
Erreur("Ne choisissez pas un nom commun comme mot de passe")
RepriseSaisie(PASSWD)
FIN
Syntaxe
<Résultat> = OrthoDisponible()
<Résultat> : Booléen
  • Vrai si un correcteur orthographique est disponible,
  • Faux dans le cas contraire.
Remarques
La correction peut être désactivée avec la fonction ParamètreOrthographe (même si le dictionnaire est bien installé).
Composante : wd240obj.dll
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire