PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
<Variable sfConnexion>.RechercheModifié (Fonction)
En anglais : <sfConnection variable>.SeekModified
AjaxNon disponible
Recherche et récupère les enregistrements (objets Salesforce) modifiés pendant la période spécifiée.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI Cnx.Connecte() = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
ResRecupModif est un sfRésultatRechercheModifié
ResRecupModif = Cnx.RechercheModifié("Mileage__c", "20090101", "20090131")
 
Identifiant est une chaîne
POUR TOUTE CHAÎNE Identifiant DE ResRecupModif..ID SÉPARÉE PAR RC
Trace("--- ID : " + Identifiant)
FIN
Syntaxe
<Résultat> = <Connexion Salesforce>.RechercheModifié(<Fichier Salesforce> , <Date de début> , <Date de fin>)
<Résultat> : Variable de type sfRésultatRechercheModifié
Nom de la variable de type sfRésultatRechercheModifié contenant les données résultat.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Fichier Salesforce> : Chaîne de caractères
Nom du fichier Salesforce à traiter. Ce nom doit correspondre au nom défini sous l'interface Salesforce comme le "Nom API". Dans le cas d'un fichier personnalisé, ce nom correspond au nom du fichier suivi par 2 underscores puis par la lettre "C". Par exemple : "MonCompte__C".
<Date de début> : DateHeure
Date de début de la période pour laquelle le nombre d'objets modifiés est recherché. Ce paramètre doit être au format UTC (utilisez si nécessaire la fonction DateHeureLocaleVersUTC pour réaliser la conversion).
<Date de fin> : DateHeure
Date de fin de la période pour laquelle le nombre d'objets modifiés est recherché. Ce paramètre doit être au format UTC (utilisez si nécessaire la fonction DateHeureLocaleVersUTC pour réaliser la conversion).
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd280ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire