DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
<Variable sfConnexion>.Modifie (Fonction)
En anglais : <sfConnection variable>.Modify
Modifie les enregistrements d'un fichier défini dans Salesforce. Ce fichier peut être un fichier prédéfini Salesforce ou un fichier personnalisé.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI Cnx.Connecte() = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
tabObjets est un tableau de sfObjet
ResRequête est un sfRésultatExécuteRequête
sTexteRequête est chaîne = "SELECT RecordTypeId, Beneficiaire__c, "...
"ID, Indice_de_mobiliot__c FROM BCM__c WHERE NAME='" + sRecherche + "'"
 
ResRequête = Cnx.ExécuteRequête(sTexteRequête)
 
UnEnregistrement est un sfObjet
POUR TOUT UnEnregistrement DE ResRequête.Objet
UnEnregistrement.Indice_de_mobiliot__c = "698" // Modification
Ajoute(tabObjets, UnEnregistrement)
FIN
 
tabRes est un tableau de sfRésultatSauvegarde
tabRes = Cnx.Modifie(tabObjets)
POUR TOUT res DE tabRes
Trace("Succès = "+res..Succès)
FIN
Syntaxe

Modifier les enregistrements existants Masquer les détails

<Résultat> = <Connexion Salesforce>.Modifie(<Enregistrements à modifier>)
<Résultat> : Variable de type Tableau
Tableau de variables de type sfRésultatSauvegarde contenant les données résultat, notamment les identifiants des objets effectivement modifiés.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Enregistrements à modifier> : Variable de type Tableau
Tableau de variables de type sfObjet correspondant aux enregistrements Salesforce à modifier. Ce tableau ne peut pas contenir plus de 200 éléments.

Modifier les enregistrements existants ou créer des enregistrements Masquer les détails

<Résultat> = <Connexion Salesforce>.Modifie(<Enregistrements à modifier ou créer> , <Mode> , <Identifiant externe>)
<Résultat> : Variable de type Tableau
Tableau de variables de type sfRésultatSauvegarde contenant les données résultat, notamment les identifiants des objets effectivement modifiés.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Enregistrements à modifier ou créer> : Variable de type Tableau
Tableau de variables de type sfObjet correspondant aux enregistrements Salesforce à modifier ou créer. Ce tableau ne peut pas contenir plus de 200 éléments.
<Mode> : Entier
Mode de modification utilisé :
sfCréationSiInexistantSi l'enregistrement n'existe pas, il est automatiquement créé.
<Identifiant externe> : Chaîne de caractères
Dans le cas d'un fichier personnalisé, nom de la rubrique définie comme identificateur de rubrique unique à partir d'un système externe.
  • Cette rubrique permet d'identifier l'enregistrement à modifier.
  • Cette rubrique et sa valeur sont présentes dans l'objet sfObjet à modifier.
    • Si la valeur n'existe pas, l'enregistrement sera automatiquement créé.
    • Si la valeur existe une seule fois, l'enregistrement est mis à jour.
    • Si la valeur existe plusieurs fois, une erreur est renvoyée.
Remarques
Composante : wd280ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire