PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Cas d'erreurs possibles :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
<Variable sfConnexion>.ExécuteRequête (Fonction)
En anglais : <sfConnection variable>.ExecuteQuery
AjaxNon disponible
Exécute une requête SOQL (Salesforce Object Query Language) sur une base de données Salesforce.
Exemple
// Connexion à Salesforce
Cnx est une  sfConnexion
Cnx..Login = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty" + "XXB12VCZ54"
SI Cnx.Connecte() = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
ResRequête est un sfRésultatExécuteRequête
ResRequête = Cnx.ExécuteRequête("SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")
 
UnEnregistrement est un sfObjet
POUR TOUT UnEnregistrement DE ResRequête..Objet
 Trace("---- Type : " + UnEnregistrement..TypeObjet + " | ID : " + UnEnregistrement..ID)
 Trace(UnEnregistrement..Date__c + " / " + UnEnregistrement..Miles__c + " / " + ...
UnEnregistrement..Contact__c)
FIN
Syntaxe
<Résultat> = <Connexion Salesforce>.ExécuteRequête(<Requête à exécuter> [, <Enregistrements supprimés>])
<Résultat> : Variable de type sfRésultatExécuteRequête
Variable de type sfRésultatExécuteRequête contenant les données résultat, notamment les enregistrements Salesforce correspondant au résultat de la requête.
<Connexion Salesforce> : Variable de type sfConnexion
Nom de la variable de type sfConnexion à utiliser.
<Requête à exécuter> : Chaîne de caractères
Code de la requête à exécuter. Cette requête est une requête SOQL (Salesforce Object Query Language). Pour plus de détails sur ce langage, consultez la documentation Salesforce.
<Enregistrements supprimés> : Booléen optionnel
  • Vrai pour inclure les enregistrements supprimés dans le résultat de la requête,
  • Faux (valeur par défaut) pour ne pas inclure les enregistrements supprimés dans le résultat de la requête.
Remarques

Cas d'erreurs possibles :

  • La connexion Internet n'est pas valide.
  • L'authentification n'a pas pu être réalisée correctement.
  • La réponse XML du serveur n'est pas lisible.
Pour savoir si une erreur est survenue, utilisez la variable ErreurDétectée.
Composante : wd280ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire