PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type sfEnregistrementSupprimé
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
sfEnregistrementSupprimé (Type de variable)
En anglais : sfDeletedRecord
Le type sfEnregistrementSupprimé permet de connaître les caractéristiques d'un enregistrement supprimé puis récupéré avec la fonction SFRechercheSupprimé.
Ce type de variable est utilisé par le type sfRésultatRechercheSupprimé.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Versions 20 et supérieures
Linux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
Nouveauté 20
Linux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
Linux Ce type de variable est désormais disponible pour les applications WINDEV sous Linux.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
ResRecupSuppr est un sfRésultatRechercheSupprimé
ResRecupSuppr = SFRechercheSupprimé(Cnx, "Mileage__c", "20090101", "20090131")
 
MonEnregistrement est un sfEnregistrementSupprimé
POUR TOUT MonEnregistrement DE ResRecupSuppr.EnregistrementSupprimé
Trace("--- ID : " + MonEnregistrement.ID)
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfEnregistrementSupprimé

Les propriétés suivantes peuvent être utilisées pour manipuler un enregistrement supprimé puis récupéré avec la fonction SFRechercheSupprimé :
NomType manipulé Effet
DateSuppressionDateHeureDate et heure de la suppression de l'enregistrement (au format UTC).
Cette propriété est disponible en lecture uniquement.
IDChaîne de caractèresIdentifiant de l'enregistrement supprimé.
Cette propriété est disponible en lecture uniquement.
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire