PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Propriétés spécifiques à la description des variables de type sfRésultatRechercheSupprimé
  • Fonctions manipulant le type sfRésultatRechercheSupprimé
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
sfRésultatRechercheSupprimé (Type de variable)
En anglais : sfSeekDeletedResult
AjaxNon disponible
Le type sfRésultatRechercheSupprimé permet de connaître le résultat de la fonction SFRechercheSupprimé. Les caractéristiques de ce résultat peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
ResRecupSuppr est un sfRésultatRechercheSupprimé
ResRecupSuppr = SFRechercheSupprimé(Cnx, "Mileage__c", "20090101", "20090131")
 
MonEnregistrement est un sfEnregistrementSupprimé
POUR TOUT MonEnregistrement DE ResRecupSuppr.EnregistrementSupprimé
Trace("--- ID : " + MonEnregistrement.ID)
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfRésultatRechercheSupprimé

Les propriétés suivantes peuvent être utilisées pour manipuler le résultat de la fonction SFRechercheSupprimé :
NomType manipuléEffet
DernièreDateCouverteDateHeureDate de l'enregistrement le plus récent qui est retourné par la fonction SFRechercheSupprimé.
Cette propriété est disponible en lecture seulement.
EnregistrementSuppriméTableau de sfEnregistrementSuppriméDonnées des enregistrements supprimés.
PremièreDateDisponibleDateHeureDate de l'enregistrement le plus ancien qui est retourné par la fonction SFRechercheSupprimé

Fonctions manipulant le type sfRésultatRechercheSupprimé

SFRechercheSuppriméRecherche et récupère les enregistrements (objets Salesforce) supprimés pendant la période spécifiée.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire