DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type sfRésultatDéconnecte
  • Fonctions manipulant le type sfRésultatDéconnecte
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
sfRésultatDéconnecte (Type de variable)
En anglais : sfDisconnectResult
Le type sfRésultatDéconnecte permet de connaître le compte-rendu de la fonction SFDéconnecte lors d'une déconnexion de session. Les caractéristiques de ce type de variable peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Salesforce
Cnx est une sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
...
// Déconnexion (deuxième syntaxe)
MesSessions est un tableau de chaînes
Ajoute(MesSessions, Cnx.InfoSession.IDSession)
MonRésultat est un tableau de sfRésultatDéconnecte
SI SFDéconnecte(Cnx, MesSessions, MonRésultat) = Faux ALORS
 Erreur("Une déconnexion a échoué")
 Trace(MonRésultat[1].Succès) // Affiche 0
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfRésultatDéconnecte

Les propriétés suivantes peuvent être utilisées pour manipuler le compte-rendu de la fonction SFDéconnecte :
Nom de la propriétéType manipuléEffet
ErreurTableau de sfErreurCompte-rendu d'erreurs.
SuccèsBooléen
  • Vrai si la déconnexion a été effectuée,
  • Faux dans le cas contraire.
Cette propriété est disponible en lecture seulement.

Fonctions manipulant le type sfRésultatDéconnecte

SFDéconnecteDéconnecte :
  • la plateforme Salesforce.
  • la session Salesforce en cours.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire