PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Propriétés spécifiques à la description des variables de type sfRésultatRecherche
  • Fonctions utilisant le type sfRésultatRecherche
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
sfRésultatRecherche (Type de variable)
En anglais : sfSearchResult
AjaxNon disponible
Le type sfRésultatRecherche permet de connaître le résultat de la fonction SFRecherche. Les caractéristiques de ce résultat peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Salesforce
Cnx est une  sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
Res est un sfRésultatRecherche
Res = SFRecherche(Cnx, "FIND {""John Smith""} IN NAME FIELDS")
 
MonEnregistrement est un sfObjet
 
POUR TOUT MonEnregistrement DE Res.Objet
Trace(MonEnregistrement.ID)
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfRésultatRecherche

Les propriétés suivantes peuvent être utilisées pour manipuler le résultat de la fonction SFRecherche :
Nom de la propriétéType manipuléEffet
ObjetTableau de sfObjetEnregistrements Salesforce correspondant au résultat de la recherche.

Fonctions utilisant le type sfRésultatRecherche

SFRechercheEffectue une recherche parmi les enregistrements d'une base de données Salesforce.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire