DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type sfRésultatSauvegarde
  • Fonctions manipulant le type sfRésultatSauvegarde
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
sfRésultatSauvegarde (Type de variable)
En anglais : sfSaveResult
Le type sfRésultatSauvegarde permet de connaître le résultat des fonctions SFAjoute et SFModifie. Les caractéristiques de ce résultat peuvent être connues à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Salesforce
Cnx est une  sfConnexion
Cnx.Login = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty" + "XXB12VCZ54"
SI SFConnecte(Cnx) = Faux ALORS
Erreur("La connexion a échoué")
RETOUR
FIN
 
// Récupération de données
ResRequête est un sfRésultatExécuteRequête
ResRequête = SFExécuteRequête(Cnx, "SELECT Date__c,Miles__c,Contact__c FROM Mileage__c")
 
UnEnregistrement est un sfObjet
POUR TOUT UnEnregistrement DE ResRequête.Objet
 Trace("---- Type : " + UnEnregistrement.TypeObjet + " | ID : " + UnEnregistrement.ID)
 Trace(UnEnregistrement.Date__c + " / "+ UnEnregistrement.Miles__c + ...
  " / "+ UnEnregistrement.Contact__c)
FIN
 
// Modification de données
UnEnregistrement = ResRequête.Objet[1]
UnEnregistrement.Miles__c = 698  //Modification
tabObjets est un tableau de 1 sfObjet
Ajoute(tabObjets, UnEnregistrement)
 
// Ajout d'une nouvelle donnée
NouvelEnreg est un sfObjet
NouvelEnreg.TypeObjet = "Mileage__c"
NouvelEnreg.Date__c = "2009-02-15"
NouvelEnreg.Miles__c = 222
Ajoute(tabObjets, NouvelEnreg)
 
tabRes est un tableau de sfRésultatSauvegarde
tabRes = SFModifie(Cnx, tabObjets, sfCréationSiInexistant, "IDExterne")
 
POUR TOUT res DE tabRes
Trace("Succès = " + res.Succès + " | Créé : " + res.Créé)
FIN
Remarques

Propriétés spécifiques à la description des variables de type sfRésultatSauvegarde

Les propriétés suivantes peuvent être utilisées pour manipuler le résultat des fonctions SFAjoute et SFModifie :
NomType manipuléEffet
CrééBooléen
  • Vrai si l'enregistrement a été créé,
  • Faux si l'enregistrement a été modifié ou si une erreur est survenue.
ErreurTableau de sfErreurCompte-rendu d'erreurs.
IDChaîne de caractèresIdentifiant de l'objet créé ou modifié.
Cette propriété est disponible en lecture seulement.
SuccèsBooléen
  • Vrai si la modification ou la création a été effectuée,
  • Faux dans le cas contraire.

Fonctions manipulant le type sfRésultatSauvegarde

SFAjouteCrée un enregistrement dans un fichier d'une base de données Salesforce.
SFModifieModifie les enregistrements d'un fichier défini dans Salesforce.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire