PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglTag
  • Fonctions WLangage utilisant des variables de type gglTag :
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Avertissement
A partir de Janvier 2019, les fonctions de gestion des albums de photos Google Picasa ne fonctionnent plus. En effet, l'API Google correspondante n'est plus disponible depuis Janvier 2019. Il est désormais nécessaire d'utiliser "Google Photo API".
Cette nouvelle API est accessible via la fonction AuthIdentifie et des requêtes HTTP. Pour plus de détails sur cette API, consultez https://developers.google.com/photos/library/guides/overview.
Le type gglTag permet décrire et de modifier un tag associé à un album ou à une photo d'un album Google Picasa. Les caractéristiques de ce type de variable peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Ce type de variable est utilisé par :
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx..Email = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty"
Cnx..NomApplication = "MonAppli-01"

SI GglConnecte(Cnx) = Faux ALORS
        Erreur(ErreurInfo())
FIN

// Récupération du tableau des albums disponibles
tabAlbum est un tableau de gglAlbum
tabAlbum = GglListeAlbum(Cnx)

// Récupération des tags associés au premier album
GglRemplitAlbum(Cnx, tabAlbum[1], gglAvecTag)

// Affichage des tags
MonTag est un gglTag
POUR TOUT MonTag DE tabAlbum[1]..Tag
        Trace(MonTag..Texte)
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglTag

Les propriétés suivantes peuvent être utilisées pour manipuler un tag associé à un album ou à une photo d'un album Google Picasa :
NomType manipuléEffet
AuteurgglAuteurAuteur du tag.
Cette propriété est disponible uniquement en lecture.
TexteChaîne de caractèresValeur du tag.
Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Fonctions WLangage utilisant des variables de type gglTag :

Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire