PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Lecture d'un fichier XLS
xlsDocument (Exemple)
Lecture d'un fichier XLS
Le code suivant permet de parcourir toutes les cellules des différentes feuilles d'un fichier XLS.
// Nom du fichier
sNomFichierExcel est une chaîne

// Sélection par l'utilisateur du fichier à ouvrir
sNomFichierExcel = fSélecteur("", sNomFichierExcel, "Indiquer le fichier Excel à lire", ...
"Classeur Excel (*.XLS)" + TAB + "*.XLS" + RC + "Tous fichiers (*.*)" + TAB + "*.*", ...
"*.XLS", fselOuvre + fselExiste)

// Annulation ?
SI sNomFichierExcel = "" ALORS RETOUR

// Ouvre le fichier
xlsdoc est un xlsDocument
xlsdoc = xlsOuvre(sNomFichierExcel)
SI ErreurDétectée ALORS
Erreur("Echec de l'ouverture du classeur Excel", ErreurInfo())
RETOUR
FIN

nNumFeuille est un entier
nNbLigneFeuille est un entier
nNbColonneFeuille est un entier
nNumLigne est un entier
nNumColonne est un entier

// Pour chaque feuille du classeur
POUR nNumFeuille = 1 _A_ xlsdoc..NombreFeuille
// On se positionne sur la feuille indiquée
xlsdoc..Feuille = nNumFeuille
// Nombre de lignes
nNbLigneFeuille = xlsdoc..NombreLigne
nNbColonneFeuille = xlsdoc..NombreColonne
// Jauge
JAUGE_Jauge = 0
JAUGE_Jauge..BorneMax = nNbLigneFeuille
POUR nNumLigne = 1 _A_ nNbLigneFeuille
JAUGE_Jauge++
POUR nNumColonne = 1 _A_ nNbColonneFeuille
Trace("Ligne" + nNumLigne + ", Colonne" + nNumColonne + "=" + ..
xlsdoc.Cellule[nNumLigne, nNumColonne])
FIN
FIN
FIN

Info("Lecture terminée")
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire