PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglSociété
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
gglSociété (Type de variable)
En anglais : gglOrganization (Type of variable)
Le type gglSociété permet de décrire les sociétés et organisations auxquelles appartiennent un contact.
Ce type de variable est utilisé par le type gglContact.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx..Email = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty"
Cnx..NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
        Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des contacts
tabContacts est un tableau de gglContact
tabContacts = GglListeContact(Cnx)
// Affichage des sociétés du premier contact
MonContact est un gglContact = tabContacts[1]
Org est un gglSociété dynamique
POUR TOUT Org DE MonContact..Société
        Trace(Org..Nom + " : " + Org..Libellé)
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglSociété

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type gglSociété :
NomType manipuléEffet
LibelléChaîne de caractèresDescription de la société.
NomChaîne de caractèresNom de la société.
PrincipalBooléen
  • Vrai si la société correspond à la société principale du contact,
  • Faux dans le cas contraire.
TitreChaîne de caractèresTitre du contact dans la société.
TypeConstante de type entierType de la société correspondant à une des variables suivantes :
  • gglAutre : Société à laquelle le contact est lié d'une manière non professionnelle.
  • gglBureau : Société à laquelle le contact est lié d'une manière professionnelle.
Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire