PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglGroupeContact
  • Fonctions utilisant des variables de type gglGroupeContact
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
gglGroupeContact (Type de variable)
En anglais : gglContactGroup (Type of variable)
Le type gglGroupeContact permet de décrire et de modifier un groupe de contacts utilisé par le service Google Contacts.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx..Email = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty"
Cnx..NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
FIN
...

// Récupère les groupes de contacts
tabGroupes est un tableau de gglGroupeContact
tabGroupes = GglListeGroupeContact(Cnx)

// Parcours des groupes
Grp est un gglGroupeContact dynamique
POUR TOUT Grp DE tabGroupes
Trace(Grp..Nom)
FIN
// Création d'un groupe de contacts
Cnx est un gglConnexion
Cnx..Email = "MonAdresse@gmail.com"
Cnx..MotDePasse = "MotdePasseAdresseGmail"
Cnx..NomApplication = ""
grpGoogle est un gglGroupeContact

SI GglConnecte(Cnx) = Faux ALORS
        Erreur(ErreurInfo())
SINON                
        // Ajout du groupe
        grpGoogle..Nom = "Mon Nouveau Groupe"
        SI PAS GglEcrit(Cnx, grpGoogle) ALORS
                Erreur(ErreurInfo())
        FIN        
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglGroupeContact

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type gglGroupeContact :
NomType manipuléEffet
DateMiseAJourDateHeureDate de la dernière mise à jour. Cette information est en lecture uniquement.
Remarque : La date est une date UTC (en temps universel)
IdentifiantChaîne de caractèresIdentifiant du groupe. Cette information est en lecture uniquement.
NomChaîne de caractèresNom du groupe.
Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Fonctions utilisant des variables de type gglGroupeContact

Versions 14 et supérieures
GglEcrit
Nouveauté 14
GglEcrit
GglEcrit
Crée et / ou met à jour des données sur le serveur Google (ajout ou modification de données).
Versions 14 et supérieures
GglListeGroupeContact
GglListeGroupeContact
Récupère la liste des groupes de contacts associés au compte Google spécifié.
Versions 14 et supérieures
GglSupprime
Nouveauté 14
GglSupprime
GglSupprime
Supprime des données sur le serveur Google.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire