PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglAdressePostale
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
gglAdressePostale (Type de variable)
En anglais : gglPostalAddress (Type of variable)
Le type gglAdressePostale permet de décrire et de modifier une adresse postale d'un contact.
Ce type de variable est utilisé par le type gglContact.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion
Cnx est un gglConnexion
Cnx..Email = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty"
Cnx..NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
        Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des contacts
tabContacts est un tableau de gglContact
tabContacts = GglListeContact(Cnx)
// Affichage des adresses du premier contact
UnContact est un gglContact = tabContacts[1]
UneAdresse est un gglAdressePostale dynamique
POUR TOUT UneAdresse DE UnContact..Adresse
        Trace(UneAdresse..Libellé + " : " + UneAdresse..Valeur)
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglAdressePostale

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type gglAdressePostale :
Nom Type manipulé Effet
AdresseChaîne de caractèresAdresse postale du contact.
LibelléChaîne de caractèresLibellé de description de l'adresse.
PrincipalBooléen
  • Vrai si l'adresse correspond à l'adresse principale du contact,
  • Faux dans le cas contraire.
TypeConstante de type entierType de l'adresse correspondant à une des variables suivantes :
  • gglAutre : Autre type d'adresse.
  • gglBureau : Adresse professionnelle.
  • gglDomicile : Adresse du domicile.
Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire