PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglTéléphone
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
gglTéléphone (Type de variable)
En anglais : gglPhoneNumber (Type of variable)
Le type gglTéléphone permet de décrire et de modifier le numéro de téléphone d'un contact.
Ce type de variable est utilisé par le type gglContact.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx..Email = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty"
Cnx..NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
        Erreur(ErreurInfo())
FIN

...

// Récupération du tableau des contacts
tabContacts est un tableau de gglContact
tabContacts = GglListeContact(Cnx)

// Affichage des téléphones du premier contact
MonContact est un gglContact = tabContacts[1]
MonTéléphoneContact est un gglTéléphone dynamique
POUR TOUT MonTéléphoneContact DE MonContact..Téléphone
        Trace(MonTéléphoneContact..Libellé + " : " + MonTéléphoneContact..Numéro)
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglTéléphone

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type gglTéléphone :
NomType manipuléEffet
LibelléChaîne de caractèresDescription du numéro de téléphone.
NuméroChaîne de caractèresNuméro de téléphone.
PrincipalChaîne de caractères
  • Vrai si le numéro correspond au numéro de téléphone principal du contact,
  • Faux dans le cas contraire.
TypeConstante de type entierType du numéro de téléphone correspondant à une des variables suivantes :
  • gglAutre : Autre numéro.
  • gglBureau : Numéro professionnel.
  • gglDomicile : Numéro du domicile.
  • gglFax : Numéro de fax.
  • gglFaxDomicile : Numéro de fax du domicile.
  • gglFaxTravail : Numéro de fax professionnel.
  • gglPager : Numéro de pager / bippeur.
  • gglPériphériqueMobile : Numéro du téléphone portable.
Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire