PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglEmail
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type gglEmail permet de décrire et de modifier une adresse email d'un contact.
Ce type de variable est utilisé par le type gglContact.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx.Email = "balthazar@gmail.com"
Cnx.MotDePasse = "azerty"
Cnx.NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des contacts
tabContacts est un tableau de gglContact
tabContacts = GglListeContact(Cnx)
 
// Affichage des emails du premier contact
UnContact est un gglContact = tabContacts[1]
UnEmail est un gglEmail dynamique
POUR TOUT UnEmail DE UnContact.Email
Trace(UnEmail.Libellé + " : " + UnEmail.Adresse)
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglEmail

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type gglEmail :
NomType manipuléEffet
AdresseChaîne de caractères UnicodeAdresse email du contact.
LibelléChaîne de caractères UnicodeLibellé de description de l'adresse.

Si la propriété Libellé est renseignée, la propriété Type doit être vide et inversement.
PrincipalBooléen
  • Vrai si l'email correspond à l'adresse email principale du contact,
  • Faux dans le cas contraire.
TypeConstante de type entierType de l'adresse email correspondant à une des variables suivantes :
  • gglAutre : Autre type d'adresse.
  • gglBureau : Adresse professionnelle.
  • gglDomicile : Adresse du domicile.
Si la propriété Libellé est renseignée, la propriété Type doit être vide et inversement.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire