PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple d'utilisation des variables de type gglParamètreCarte
gglParamètreCarte (Exemple)
Exemple d'utilisation des variables de type gglParamètreCarte
Exemple permettant d'afficher des marqueurs (ici un carré de 50 marqueurs).
MapsAPIKey est une chaîne = "clé google maps"
// Paramétrage d'une carte
CarteGglParams est un gglParamètreCarte
// Définition des marqueurs
MarqueGgl est un gglMarqueur

POUR i = 1 A 50
MarqueGgl..Taille = gglGrand
// Noir, Blanc, VertClair, JauneClair, BleuClair, GrisClair, RougeClair.
SELON i
CAS 1<=*<=12
MarqueGgl..Latitude = 47.022356 + (i/30)
MarqueGgl..Longitude = 52.423654
MarqueGgl..Couleur = BleuClair
// Lettre (modulo 26 donc)
MarqueGgl..Lettre=Caract(Asc("A") + modulo(i-1,26))

CAS 13<=*<=24
MarqueGgl..Latitude = 47.022356
MarqueGgl..Longitude = 52.423654 + ((i-13)/30)
MarqueGgl..Couleur = VertClair
// Chiffres
MarqueGgl..Lettre=Caract(Asc("0") + modulo(i-13,10))

CAS 25<=*<=36
MarqueGgl..Latitude = 47.022356 + ((i-24)/30)
MarqueGgl..Longitude = 52.423654 + (11/30)
MarqueGgl..Couleur = JauneClair
// Lettre (modulo 26 donc)
MarqueGgl..Lettre=Caract(Asc("A") + modulo(i-25,26))

CAS 37<=*<=48
MarqueGgl..Latitude = 47.022356+(13/30)
MarqueGgl..Longitude = 52.423654 + ((i-37)/30)
MarqueGgl..Couleur = RougeClair
// Chiffres
MarqueGgl..Lettre=Caract(Asc("0") + modulo(i-37,10))

CAS 49
MarqueGgl..Latitude = 47.022356 + (6/30)
MarqueGgl..Longitude = 52.423654 + (5/30)
MarqueGgl..Couleur = Blanc
MarqueGgl..Lettre="W"
CAS 50
MarqueGgl..Latitude = 47.022356 + (6/30)
MarqueGgl..Longitude = 52.423654 + (6/30)
MarqueGgl..Couleur = Blanc
MarqueGgl..Lettre="D"
AUTRE CAS
Info("50 marqueurs maximum")
FIN

// Ajout des marqueurs
Ajoute(CarteGglParams..Marqueur, MarqueGgl)
FIN

// Paramètres divers
CarteGglParams..Format = gglJPG
CarteGglParams..Cadre = Vrai

IMG_CARTE..Largeur = 600
IMG_CARTE..Hauteur = 600
IMG_CARTE = GglRécupèreCarte(MapsAPIKey, 47.25, 52.6,10, 600, 600, gglHybride, CarteGglParams)
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire