PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type gglContact
  • Fonctions utilisant le type gglContact
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
gglContact (Type de variable)
En anglais : gglContact (Type of variable)
Le type gglContact permet de décrire et de modifier un contact utilisé par le service Google Contacts.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
// Connexion à Google
Cnx est un gglConnexion
Cnx..Email = "balthazar@gmail.com"
Cnx..MotDePasse = "azerty"
Cnx..NomApplication = "MonAppli-01"
SI GglConnecte(Cnx) = Faux ALORS
        Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des contacts
tabContacts est un tableau de gglContact
tabContacts = GglListeContact(Cnx)
// Parcours des contacts
UnContact est un gglContact
POUR TOUT UnContact DE tabContacts
        Trace(UnContact..Nom)
FIN
// Connexion à Google
Cnx est un gglConnexion
Cnx..Email = "email_utilisateur_final@gmail.com"
Cnx..ClientID = "387756281032-qffa6dajjd5348iqhi558dkd98xxxxxx.apps.googleusercontent.com"
Cnx..ClientSecret = "S13DCA6KkYh1EgPv9-jLxxxh"
SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
FIN
...
// Récupération du tableau des contacts
tabContacts est un tableau de gglContact
tabContacts = GglListeContact(Cnx)
// Parcours des contacts
UnContact est un gglContact
POUR TOUT UnContact DE tabContacts
Trace(UnContact..Nom)
FIN
// Ajout d'un contact dans gmail
Cnx est un gglConnexion
Cnx..Email = "MonAdresse@gmail.com"
Cnx..MotDePasse = "MotDePasseAdresseGmail"
Cnx..NomApplication = ""
ctcGoogle est un gglContact

SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
SINON
// Ajout du contact
ctcGoogle..Nom = "Mon nouveau contact"
ctcGoogle..Notes = "Notes de mon contact"
SI PAS GglEcrit(Cnx, ctcGoogle) ALORS
Erreur(ErreurInfo())
FIN
FIN
// Ajout d'un contact dans gmail
Cnx est un gglConnexion
Cnx..Email = "email_utilisateur_final@gmail.com"
Cnx..ClientID = "387756281032-qffa6dajjd5348iqhi558dkd98xxxxxx.apps.googleusercontent.com"
Cnx..ClientSecret = "S13DCA6KkYh1EgPv9-jLxxxh"
ctcGoogle est un gglContact

SI GglConnecte(Cnx) = Faux ALORS
Erreur(ErreurInfo())
SINON
// Ajout du contact
ctcGoogle..Nom = "Mon nouveau contact"
ctcGoogle..Notes = "Notes de mon contact"
SI PAS GglEcrit(Cnx, ctcGoogle) ALORS
Erreur(ErreurInfo())
FIN
FIN
Remarques

Propriétés spécifiques à la description des variables de type gglContact

Les propriétés suivantes peuvent être utilisées pour manipuler une variable de type gglContact :
NomType manipuléEffet
AdressePostaleTableau de gglAdressePostaleAdresses postales du contact.
Versions 18 et supérieures
DateModification
Nouveauté 18
DateModification
DateModification
Chaîne de caractèresDate de dernière modification du contact.
Cette propriété est disponible uniquement en lecture.
EmailTableau de gglEmailAdresses emails du contact.
GroupeTableauTableau des identifiants des groupes de contacts auxquels le contact appartient.
Versions 18 et supérieures
Identifiant
Nouveauté 18
Identifiant
Identifiant
Chaîne de caractèresIdentifiant Google du contact.
Cette propriété est disponible uniquement en lecture.
MessagerieInstantanéeTableau de gglMessagerieInstantanéeAdresses de messagerie instantanée du contact.
NomChaîne de caractèresNom du contact.
NotesChaîne de caractèresNotes associées au contact.
SociétéTableau de gglSociétéSociétés / organisations associées au contact.
TéléphoneTableau de gglTéléphoneNuméro de téléphone d'un contact


Remarque : Ces propriétés peuvent être utilisées avec une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>

Fonctions utilisant le type gglContact

Versions 14 et supérieures
GglEcrit
Nouveauté 14
GglEcrit
GglEcrit
Crée et / ou met à jour des données sur le serveur Google (ajout ou modification de données).
Versions 14 et supérieures
GglListeContact
Nouveauté 14
GglListeContact
GglListeContact
Récupère la liste des contacts associés au compte Google spécifié.
Versions 14 et supérieures
GglListeContactParRequête
GglListeContactParRequête
Récupère une liste de contacts à partir de paramètres personnalisés.
Versions 14 et supérieures
GglListeGroupeContact
GglListeGroupeContact
Récupère la liste des groupes de contacts associés au compte Google spécifié.
Versions 14 et supérieures
GglSupprime
Nouveauté 14
GglSupprime
GglSupprime
Supprime des données sur le serveur Google.
Version minimum requise
  • Version 14
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire