PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Équivalence
  • Divers
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Renvoie l'indice de l'élément sélectionné dans un champ Liste, Liste image ou Combo.
Rappel : L'élément sélectionné correspond à l'élément en cours sur lequel le bandeau de sélection est affiché.
Remarque : La fonction <Liste>.Select peut être utilisée indifféremment sur :
  • les champs Liste fichier ou Liste par programmation,
  • les champs Liste monosélection ou multisélection.
Exemple
// Indice de l'élément sélectionné dans le champ "LISTE_ListeClient"
ResIndiceElément = LISTE_ListeClient.Select()
// Lignes sélectionnées dans un champ Liste multisélection
i est un entier = 1
IndiceLigneSelectionnee est un entier
IndiceLigneSelectionnee = LISTE_Liste1.Select(1)
TANTQUE IndiceLigneSelectionnee <> -1
Trace("La ligne n°" + IndiceLigneSelectionnee + " est sélectionnée")
i++
IndiceLigneSelectionnee = LISTE_Liste1.Select(i)
FIN
 
// Équivalent à :
// POUR TOUTE LIGNE SELECTIONNEE DE LISTE_Liste1
// Trace("La ligne n°" + LISTE_Liste1 + " est sélectionnée")
// FIN
Syntaxe
<Résultat> = <Champ Liste>.Select([<Rang>])
<Résultat> : Entier
  • Indice de l'élément sélectionné dans le champ Liste (ou Combo) spécifiée,
  • -1 si aucun élément n'est sélectionné.
Dans le cas d'un champ Liste multisélection, il est nécessaire de préciser le rang de l'élément sélectionné (paramètre <Rang>).
<Champ Liste> : Nom de champ
Nom du champ Liste (ou Combo) à manipuler.
<Rang> : Entier optionnel
Rang de la sélection dans le cas d'un champ Liste multisélection. Si ce paramètre n'est pas spécifié, l'indice du premier élément sélectionné est renvoyé.
Par exemple : Pour récupérer le premier élément sélectionné, le rang sera 1, pour récupérer le deuxième élément sélectionné, le rang sera 2, etc.
Remarques

Équivalence

Les syntaxes suivantes sont équivalentes :
Indice est un entier
Indice = <Champ Liste>
et
Indice = <Champ Liste>.Select()

Divers

  • Pour connaître l'indice de l'élément sélectionné dans un champ Table, utilisez la fonction <Table>.Select.
  • La fonction <Liste>.Select peut être utilisée sur une colonne d'un champ Table de type "Combo".
Composante : wd270obj.dll
Version minimum requise
  • Version 23
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire