PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Mode de fonctionnement
  • Limitation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
ServiceArrête (Fonction)
En anglais : ServiceStop
Arrête un service. Ce service peut être un service présent sur le poste local ou sur un poste distant.
Exemple
// Arrête le service présent dans la table TABLE_Service
SI ServiceArrête(COL_Nom[TABLE_Service]) = Vrai ALORS
SI ServiceAttendEtat(COL_Nom[TABLE_Service], serviceEtatArrêté, 10) = -1 ALORS
 Erreur(ErreurInfo())
FIN
SINON
Erreur(ErreurInfo())
FIN
Syntaxe
<Résultat> = ServiceArrête(<Nom du service> [, <Poste distant>])
<Résultat> : Booléen
  • Vrai si la demande d'arrêt du service a été transmise au gestionnaire de services,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Nom du service> : Chaîne de caractères (avec guillemets)
Nom du service à arrêter.
<Poste distant> : Chaîne de caractères optionnelle (avec guillemets)
Adresse IP du poste distant au format xxx.xxx.xxx.xxx (obtenu par la fonction NetAdresseIP) ou nom du poste distant (obtenu par la fonction NetNomMachine). Ce paramètre permet d'arrêter un service sur un autre poste. Pour utiliser cette option, l'utilisateur doit être administrateur de la machine distante.
Si ce paramètre n'est pas précisé ou correspond à une chaîne vide, le service est manipulé en local.
Remarques
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsAjaxCode Utilisateur (MCU)

Mode de fonctionnement

La fonction ServiceArrête demande au gestionnaire de services d'arrêter le service. Cette opération peut ne pas être effectuée immédiatement. Pour connaître l'état du service, utilisez la fonction ServiceAttendEtat.

Limitation

Les fonctions de gestion des services ne fonctionnent pas sous les systèmes suivants : Windows 98 ou Me.
Composante : wd250std.dll
Version minimum requise
  • Version 12
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire