PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
ServiceListe (Fonction)
En anglais : ServiceList
Liste les services présents sur le poste en cours ou sur le poste distant indiqué.
Exemple
sService_Liste est une chaîne

// Vide la table
TableSupprimeTout(TABLE_Service)
// TABLE_Service contient 2 colonnes texte: "Nom" et "Description"

// Liste les services
sService_Liste = ServiceListe()
SI sService_Liste <> "" ALORS
POUR TOUTE CHAÎNE sServiceInfo DE sService_Liste SEPAREE PAR RC
TableAjoute(TABLE_Service, sServiceInfo)
FIN

SINON
Erreur(ErreurInfo(errComplet))
FIN
Syntaxe
<Résultat> = ServiceListe([<Poste distant>])
<Résultat> : Chaîne de caractères
  • Liste des services, renvoyée selon le format suivant :
    <Nom du service 1> + TAB + <Description du service 1> + RC + ...
    + <Nom du service N> + TAB + <Description du service N>
  • Chaîne vide ("") en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Poste distant> : Chaîne de caractères optionnelle (avec guillemets)
Adresse IP du poste distant au format xxx.xxx.xxx.xxx (obtenu par la fonction NetAdresseIP) ou nom du poste distant (obtenu par la fonction NetNomMachine).
Ce paramètre permet de lister les services présents sur un autre poste.
Pour utiliser cette option, l'utilisateur peut ne pas être administrateur de la machine distante (il doit au moins posséder les droits permettant de lister les services sur cette machine).
Si ce paramètre n'est pas précisé ou correspond à une chaîne vide (""), le service est manipulé en local.
Remarques
Les fonctions de gestion des services ne fonctionnent pas sous les systèmes suivants : Windows 98 ou Me.
Composante : wd250std.dll
Version minimum requise
  • Version 12
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire