PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Cas particuliers
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Réinitialise :
  • WINDEVWEBDEV - Code Serveur la structure RendezVous.
    Rappel : Cette fonction ne permet pas de réinitialiser la structure RendezVous d'une messagerie Outlook Express.
  • AndroidWidget Android la variable de type RendezVous utilisée par un calendrier (ou agenda) d'un appareil Android.
Exemple
WINDEVWEBDEV - Code Serveur
// Ouverture d'une session Lotus Notes
IDSession est un entier
IDSession = EmailOuvreSessionNotes("MotDePasse", "ServeurMars", ...
"mail/julie.nsf", "C:\Lotus Notes\julie.id")
// Initialisation des variables de la structure RendezVous
RendezVousRAZ()
// Renseignements des variables pour le nouveau rendez-vous
mRendezVous.Objet = "Réunion commerciaux"
mRendezVous.DateDébut = "20070125100000"
mRendezVous.Lieu = "Salle 3B"
mRendezVous.NbParticipant = 3
mRendezVous.Participant[1] = "Romain"
mRendezVous.Participant[2] = "Lucas"
mRendezVous.Participant[3] = "Stéphane"
// Ajout du rendez-vous
SI RendezVousAjoute(IDSession) = Vrai ALORS
Info("Rendez-vous ajouté")
SINON
Erreur("Erreur lors de l'ajout", ErreurInfo())
FIN
AndroidWidget Android
// Ajout d'un nouveau rendez-vous
RendezVousRAZ(gRDV)
gRDV.Titre = SAI_Titre
gRDV.DateDébut = SAI_DateDeb + SAI_HeureDeb
gRDV.DateFin = SAI_DateFin + SAI_HeureFin
gRDV.Lieu = SAI_Lieu
gRDV.Contenu = SAI_Desc
SI SAI_Fuseau <> "" ALORS
gRDV.FuseauHoraire = SAI_Fuseau
FIN
gRDV.Auteur = SAI_Auteur
gRDV.Invité = SAI_Invités
gRDV.JournéeEntière = INT_Jentière[1]
 
SI RendezVousAjoute(gCal, gRDV) ALORS
ToastAffiche("RDV ajouté")
SINON
Erreur(ErreurInfo())
FIN
Syntaxe
WINDEVWEBDEV - Code Serveur

Réinitialiser la structure RendezVous

RendezVousRAZ()
AndroidWidget Android

Réinitialiser une variable de type RendezVous Masquer les détails

RendezVousRAZ(<Rendez-vous>)
<Rendez-vous> : Variable de type RendezVous
Nom de la variable de type RendezVous à réinitialiser.
Remarques
AndroidWidget Android

Cas particuliers

  • La fonction RendezVousRAZ peut être utilisée dans l'émulateur mais pas dans le simulateur.
Composante : wd280com.dll
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire