PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Agenda d'une messagerie Lotus Notes ou Outlook
  • Agenda Android
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Ajoute un rendez-vous :
  • WINDEVWEBDEV - Code Serveur dans l'agenda d'une messagerie Lotus Notes ou Outlook. La structure RendezVous permet de définir les données de ce contact.
    Rappel : Cette fonction ne permet pas d'ajouter un rendez-vous dans l'agenda d'une messagerie Outlook Express.
  • Versions 18 et supérieures
    AndroidWidget Android dans un calendrier (ou agenda) d'un appareil Android.
    Nouveauté 18
    AndroidWidget Android dans un calendrier (ou agenda) d'un appareil Android.
    AndroidWidget Android dans un calendrier (ou agenda) d'un appareil Android.
  • Versions 21 et supérieures
    iPhone/iPad dans un calendrier (ou agenda) d'un appareil iOS.
    Nouveauté 21
    iPhone/iPad dans un calendrier (ou agenda) d'un appareil iOS.
    iPhone/iPad dans un calendrier (ou agenda) d'un appareil iOS.
Versions 18 et supérieures
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Nouveauté 18
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Widget Android Cette fonction est désormais disponible en mode Widget Android.
Versions 21 et supérieures
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
Nouveauté 21
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
iPhone/iPad Cette fonction est désormais disponible pour les applications iPhone/iPad.
WINDEVWEBDEV - Code Serveur
// Ouverture d'une session Lotus Notes
IDSession est un entier
IDSession = EmailOuvreSessionNotes("MotDePasse", "ServeurMars", ...
"mail/julie.nsf", "C:\Lotus Notes\julie.id")
// Initialisation des variables de la structure RendezVous
RendezVousRAZ()
// Renseignements des variables pour le nouveau rendez-vous
mRendezVous.Objet = "Réunion commerciaux"
mRendezVous.DateDébut = "20070125100000"
mRendezVous.Lieu = "Salle 3B"
mRendezVous.NbParticipant = 3
mRendezVous.Participant[1] = "Romain"
mRendezVous.Participant[2] = "Lucas"
mRendezVous.Participant[3] = "Stéphane"
// Ajout du rendez-vous
SI RendezVousAjoute(IDSession) = Vrai ALORS
Info("Rendez-vous ajouté")
SINON
Erreur("Erreur lors de l'ajout", ErreurInfo())
FIN
Versions 18 et supérieures
AndroidWidget Android
gRDV est un RendezVous
gCal est un Calendrier
tabCalendrier est un tableau de Calendrier
// Récupère la liste des calendriers
tabCalendrier = RendezVousListeCalendrier()
gCal = tabCalendrier[1]
 
// Ajout d'un nouveau rendez-vous dans le premier calendrier
gRDV..Titre = SAI_Titre
gRDV..DateDébut = SAI_DateDeb + SAI_HeureDeb
gRDV..DateFin = SAI_DateFin + SAI_HeureFin
gRDV..Lieu = SAI_Lieu
gRDV..Contenu = SAI_Desc
SI SAI_Fuseau <> "" ALORS
gRDV..FuseauHoraire = SAI_Fuseau
FIN
gRDV..Auteur = SAI_Auteur
gRDV..Invité = SAI_Invités
gRDV..JournéeEntière = INT_Jentière[1]
 
SI RendezVousAjoute(gCal, gRDV) ALORS
ToastAffiche("RDV ajouté")
SINON
Erreur(ErreurInfo())
FIN
Nouveauté 18
AndroidWidget Android
gRDV est un RendezVous
gCal est un Calendrier
tabCalendrier est un tableau de Calendrier
// Récupère la liste des calendriers
tabCalendrier = RendezVousListeCalendrier()
gCal = tabCalendrier[1]
 
// Ajout d'un nouveau rendez-vous dans le premier calendrier
gRDV..Titre = SAI_Titre
gRDV..DateDébut = SAI_DateDeb + SAI_HeureDeb
gRDV..DateFin = SAI_DateFin + SAI_HeureFin
gRDV..Lieu = SAI_Lieu
gRDV..Contenu = SAI_Desc
SI SAI_Fuseau <> "" ALORS
gRDV..FuseauHoraire = SAI_Fuseau
FIN
gRDV..Auteur = SAI_Auteur
gRDV..Invité = SAI_Invités
gRDV..JournéeEntière = INT_Jentière[1]
 
SI RendezVousAjoute(gCal, gRDV) ALORS
ToastAffiche("RDV ajouté")
SINON
Erreur(ErreurInfo())
FIN
AndroidWidget Android
gRDV est un RendezVous
gCal est un Calendrier
tabCalendrier est un tableau de Calendrier
// Récupère la liste des calendriers
tabCalendrier = RendezVousListeCalendrier()
gCal = tabCalendrier[1]
 
// Ajout d'un nouveau rendez-vous dans le premier calendrier
gRDV..Titre = SAI_Titre
gRDV..DateDébut = SAI_DateDeb + SAI_HeureDeb
gRDV..DateFin = SAI_DateFin + SAI_HeureFin
gRDV..Lieu = SAI_Lieu
gRDV..Contenu = SAI_Desc
SI SAI_Fuseau <> "" ALORS
gRDV..FuseauHoraire = SAI_Fuseau
FIN
gRDV..Auteur = SAI_Auteur
gRDV..Invité = SAI_Invités
gRDV..JournéeEntière = INT_Jentière[1]
 
SI RendezVousAjoute(gCal, gRDV) ALORS
ToastAffiche("RDV ajouté")
SINON
Erreur(ErreurInfo())
FIN
AndroidWidget AndroidiPhone/iPad
gRDV est un RendezVous
gCal est un Calendrier
tabCalendrier est un tableau de Calendrier
// Récupère la liste des calendriers
tabCalendrier = RendezVousListeCalendrier()
gCal = tabCalendrier[1]
 
// Ajout d'un nouveau rendez-vous dans le premier calendrier
gRDV..Titre = SAI_Titre
gRDV..DateDébut = SAI_DateDeb + SAI_HeureDeb
gRDV..DateFin = SAI_DateFin + SAI_HeureFin
gRDV..Lieu = SAI_Lieu
gRDV..Contenu = SAI_Desc
SI SAI_Fuseau <> "" ALORS
gRDV..FuseauHoraire = SAI_Fuseau
FIN
gRDV..Auteur = SAI_Auteur
gRDV..Invité = SAI_Invités
gRDV..JournéeEntière = INT_Jentière[1]
 
SI RendezVousAjoute(gCal, gRDV) ALORS
ToastAffiche("RDV ajouté")
SINON
Erreur(ErreurInfo())
FIN
Syntaxe

Ajouter un rendez-vous dans l'agenda d'une messagerie Lotus Notes ou Outlook Masquer les détails

<Résultat> = RendezVousAjoute(<Identifiant de la session>)
<Résultat> : Booléen
  • Vrai si l'ajout a été effectué,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Identifiant de la session> : Entier
Identifiant de la session à utiliser. Cet identifiant est renvoyé par une des fonctions suivantes : EmailOuvreSessionNotes, EmailOuvreSessionOutlook, NotesOuvreBase ou OutlookOuvreSession.
Versions 18 et supérieures
AndroidWidget Android Cette syntaxe est disponible à partir de la version 180046.

Ajouter un rendez-vous dans un calendrier (ou agenda) d'un appareil Android Masquer les détails

<Résultat> = RendezVousAjoute(<Calendrier> , <Rendez-vous>)
<Résultat> : Booléen
  • Vrai si l'ajout a été effectué,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Calendrier> : Variable de type Calendrier
Nom de la variable de type Calendrier correspondant au calendrier Android dans lequel le rendez-vous doit être ajouté.
<Rendez-vous> : Variable de type RendezVous
Nom de la variable de type RendezVous correspondant au rendez-vous à ajouter dans le calendrier spécifié de l'appareil Android.
Nouveauté 18
AndroidWidget Android Cette syntaxe est disponible à partir de la version 180046.

Ajouter un rendez-vous dans un calendrier (ou agenda) d'un appareil Android Masquer les détails

<Résultat> = RendezVousAjoute(<Calendrier> , <Rendez-vous>)
<Résultat> : Booléen
  • Vrai si l'ajout a été effectué,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Calendrier> : Variable de type Calendrier
Nom de la variable de type Calendrier correspondant au calendrier Android dans lequel le rendez-vous doit être ajouté.
<Rendez-vous> : Variable de type RendezVous
Nom de la variable de type RendezVous correspondant au rendez-vous à ajouter dans le calendrier spécifié de l'appareil Android.
AndroidWidget Android Cette syntaxe est disponible à partir de la version 180046.

Ajouter un rendez-vous dans un calendrier (ou agenda) d'un appareil Android Masquer les détails

<Résultat> = RendezVousAjoute(<Calendrier> , <Rendez-vous>)
<Résultat> : Booléen
  • Vrai si l'ajout a été effectué,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Calendrier> : Variable de type Calendrier
Nom de la variable de type Calendrier correspondant au calendrier Android dans lequel le rendez-vous doit être ajouté.
<Rendez-vous> : Variable de type RendezVous
Nom de la variable de type RendezVous correspondant au rendez-vous à ajouter dans le calendrier spécifié de l'appareil Android.
AndroidWidget AndroidiPhone/iPad

Ajouter un rendez-vous dans un calendrier (ou agenda) d'un appareil Android/iOS Masquer les détails

<Résultat> = RendezVousAjoute(<Calendrier> , <Rendez-vous>)
<Résultat> : Booléen
  • Vrai si l'ajout a été effectué,
  • Faux dans le cas contraire. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Calendrier> : Variable de type Calendrier
Nom de la variable de type Calendrier correspondant au calendrier Android/iOS dans lequel le rendez-vous doit être ajouté.
<Rendez-vous> : Variable de type RendezVous
Nom de la variable de type RendezVous correspondant au rendez-vous à ajouter dans le calendrier spécifié de l'appareil Android/iOS.
Remarques
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)

Agenda d'une messagerie Lotus Notes ou Outlook

  • Lors de la création d'un rendez-vous avec rappel dans Outlook, le rappel s'affiche immédiatement quelle que soit la date du rendez-vous.
  • Les rendez-vous ajoutés sont des rendez-vous de type "meeting" (et non pas des rendez-vous de type "appointment"). Il est possible de modifier le type du rendez-vous en modifiant le champ "AppointmentType" du rendez-vous créé (par exemple avec la fonction NotesModifieChamp).
    Les différentes valeurs possibles pour les types sont :
    • "0" : appointment
    • "1" : anniversary
    • "2" : event
    • "3" : meeting
    • "4" : reminder
    Exemple :
    NotesModifieChamp(ID, "AppointmentType", "0")
  • Versions 18 et supérieures
    Sous Outlook, il est possible de spécifier le mode de gestion des contacts/participants lors de l'ouverture de la session (fonction EmailOuvreSessionOutlook ou fonction OutlookOuvreSession).
    Nouveauté 18
    Sous Outlook, il est possible de spécifier le mode de gestion des contacts/participants lors de l'ouverture de la session (fonction EmailOuvreSessionOutlook ou fonction OutlookOuvreSession).
    Sous Outlook, il est possible de spécifier le mode de gestion des contacts/participants lors de l'ouverture de la session (fonction EmailOuvreSessionOutlook ou fonction OutlookOuvreSession).
Versions 18 et supérieures
AndroidWidget Android

Agenda Android

  • La fonction RendezVousAjoute peut être utilisée dans l'émulateur mais pas dans le simulateur.
  • La fonction RendezVousAjoute est disponible uniquement sur les appareils disposant d’une version d’Android supérieure ou égale à la version 4.0 (api level 14). Si la fonction est utilisée avec une version antérieure du système, une erreur fatale sera déclenchée.
    Rappel : Pour connaître la version du système Android sur laquelle s’exécute l’application, utilisez la fonction SysVersionAndroid.
Nouveauté 18
AndroidWidget Android

Agenda Android

  • La fonction RendezVousAjoute peut être utilisée dans l'émulateur mais pas dans le simulateur.
  • La fonction RendezVousAjoute est disponible uniquement sur les appareils disposant d’une version d’Android supérieure ou égale à la version 4.0 (api level 14). Si la fonction est utilisée avec une version antérieure du système, une erreur fatale sera déclenchée.
    Rappel : Pour connaître la version du système Android sur laquelle s’exécute l’application, utilisez la fonction SysVersionAndroid.
AndroidWidget Android

Agenda Android

  • La fonction RendezVousAjoute peut être utilisée dans l'émulateur mais pas dans le simulateur.
  • La fonction RendezVousAjoute est disponible uniquement sur les appareils disposant d’une version d’Android supérieure ou égale à la version 4.0 (api level 14). Si la fonction est utilisée avec une version antérieure du système, une erreur fatale sera déclenchée.
    Rappel : Pour connaître la version du système Android sur laquelle s’exécute l’application, utilisez la fonction SysVersionAndroid.
Composante : wd250com.dll
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire