PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Conversion d'un hash au format binaire vers le format hexadécimal
  • Conversion d'un hash au format hexadécimal vers le format binaire
HashChaîne (Exemple)
Conversion d'un hash au format binaire vers le format hexadécimal
sHash_Binaire est une chaîne = HashChaîne(HA_SHA_160, "Chaîne", "Clé")
sHash_Hexa est une chaîne
POUR nIndice = 1 _À_ Taille(sHash_Binaire)
sHash_Hexa += NumériqueVersChaîne(Asc(sHash_Binaire[[nIndice]]),"02x")
FIN
Trace(sHash_Hexa)
Conversion d'un hash au format hexadécimal vers le format binaire
sHash_Hexa est une chaîne = "918d40029ce4fc9702a62fdee8977b66b38b9ccf"
sHash_Binaire est une chaîne
POUR nInd = 1 _À_ Taille(sHash_Hexa) PAS 2
sHash_Binaire += Caract(Val(sHash_Hexa[[nInd SUR 2]], "x"))
FIN
SI HashVérifieChaîne(HA_SHA_160, "Chaîne", sHash_Binaire, "Clé") = Vrai ALORS
Info("Hash OK")
FIN
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire