PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
NotesDocumentCherche (Fonction)
En anglais : NotesDocumentSeek
Recherche un document dans Lotus Notes.
Remarque : Pour rechercher un document dans une vue, utilisez la fonction NotesVueChercheDernier ou NotesVueCherchePremier.
Exemple
// Ouverture d'une session Lotus Notes
IDSession est un entier
IDSession = EmailOuvreSessionNotes("MotDePasse", "ServeurMars", ...
"mail\julie.nsf", "C:\Users\Julie\AppData\Local\Lotus\Notes\Data\user.id")
...
// Recherche des documents contenant la chaîne "pc soft"
SI NotesDocumentCherche(IDSession, "@contains(@lowercase(categories);'pc soft')") = Vrai ALORS
// Enumération des documents trouvés
TANTQUE NotesEnDehors(IDSession) = Faux
// Affiche le nom des documents trouvés dans un champ Liste
ListeAjoute(LISTE_DocumentTrouve, NotesChamp(IDSession, "Nom"))
// Document trouvé suivant
NotesDocumentSuivant(IDSession)
FIN
SINON
Info("Aucun document n'a été trouvé")
FIN
Syntaxe
<Résultat> = NotesDocumentCherche(<Identifiant de la session> , <Formule Lotus Notes>)
<Résultat> : Booléen
  • Vrai si un ou plusieurs documents ont été trouvés,
  • Faux dans le cas contraire. En cas d'erreur, la variable ErreurDétectée est à Vrai. Pour connaître le libellé de l'erreur, utilisez la fonction ErreurInfo avec la constante errMessage.
Si aucun document n'a été trouvé, la variable ErreurDétectée reste à Faux et la fonction NotesEnDehors renvoie Vrai.
<Identifiant de la session> : Entier
Identifiant de la session à utiliser. Cet identifiant est renvoyé par la fonction EmailOuvreSessionNotes ou NotesOuvreBase.
<Formule Lotus Notes> : Chaîne de caractères (avec guillemets)
Formule de sélection des documents dans Lotus Notes. Pour plus de détails sur ces formules de sélection, consultez la documentation de Lotus Notes.
Composante : wd260mess.dll
Version minimum requise
  • Version 11
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire