PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemple
  • Utilisation du mot-clé SORTIR pour interrompre une procédure
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 34 : 'Sortir' est interdit en dehors des boucles
Cause
Vous avez utilisé le mot-clé SORTIR pour interrompre une procédure.
Rappel : Le mot-clé SORTIR doit être utilisé uniquement pour interrompre une boucle.
Correction
Pour sortir d'une procédure, utilisez les mots-clés RETOUR ou RENVOYER (si une valeur doit être renvoyée au traitement appelant).
Exemple

Utilisation du mot-clé SORTIR pour interrompre une procédure

Code provoquant l'erreur
PROCEDURE Compare(Chiffre1, Chiffre2)
SI Chiffre1>Chiffre2 ALORS
        Info(Chiffre1 + "est supérieur à" + Chiffre2)
        SORTIR
FIN
Correction proposée
Le mot-clé SORTIR doit être remplacé par le mot-clé RETOUR.
PROCEDURE Compare(Chiffre1, Chiffre2)
SI Chiffre1>Chiffre2 ALORS
        Info(Chiffre1 + "est supérieur à" + Chiffre2)
        RETOUR
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire