PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Suppression de tous les fichiers d'une archive
  • Suppression de tous les fichiers d'une archive
zipSupprimeTout (Exemple)
Suppression de tous les fichiers d'une archive
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsJavaAjaxCode Utilisateur (MCU) Le code suivant permet de supprimer tous les fichiers d'une archive.
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
CodeErreurOuvre est un entier
CodeErreurSup est un entier
 
// Ouverture d'une archive
CodeErreurOuvre = zipOuvre(NomArchive, "C:\Répertoire\Archives\ArchivePdf.zip")
 
SI CodeErreurOuvre = 0 ALORS
// Suppression de tous les fichiers
CodeErreurSup = zipSupprimeTout(NomArchive)
SI CodeErreurSup <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurSup))
FIN
SINON
  Erreur(zipMsgErreur(CodeErreurOuvre))
FIN
 
Suppression de tous les fichiers d'une archive
Windows Mobile Le code suivant permet de supprimer tous les fichiers d'une archive.
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
CodeErreurOuvre est un entier
CodeErreurSup est un entier
 
// Ouverture d'une archive
CodeErreurOuvre = zipOuvre(NomArchive, "\Répertoire\Archives\ArchivePdf.zip")
 
SI CodeErreurOuvre = 0 ALORS
// Suppression de tous les fichiers
CodeErreurSup = zipSupprimeTout(NomArchive)
SI CodeErreurSup <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurSup))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurOuvre))
FIN
 
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire