PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Regroupement des sous-archives d'une archive multi-parties
  • Regroupement des sous-archives d'une archive multi-parties
zipRegroupe (Exemple)
Regroupement des sous-archives d'une archive multi-parties
WINDEVWEBDEV - Code ServeurEtats et RequêtesAjaxCode Utilisateur (MCU) Le code suivant permet de regrouper les sous-archives d'une archive multi-parties. La fonction zipEstMulti permet de vérifier que l'archive est une archive multi-parties.
// Déclaration et initialisation des variables
CodeErreurOuvre est un entier
CodeErreurRegroupe est un entier
EstMulti est un booléen
 
// Ouverture d'une archive
CodeErreurOuvre = zipOuvre("MonArchive", "A:\MonArchive.zip")
 
SI CodeErreurOuvre = 0 ALORS
// L'archive est-elle multi-parties ?
EstMulti = zipEstMulti("MonArchive")
// Regroupement de l'archive
CodeErreurRegroupe = zipRegroupe("MonArchive", "C:\MesArchives\ArchiveMulti.WDZ")
// Message d'erreur si les sous-archives n'ont pas été regroupées
SI CodeErreurRegroupe <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurRegroupe))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurOuvre))
FIN
 
Regroupement des sous-archives d'une archive multi-parties
Windows Mobile Le code suivant permet de regrouper les sous-archives d'une archive multi-parties. La fonction zipEstMulti permet de vérifier que l'archive est une archive multi-parties.
// Déclaration et initialisation des variables
CodeErreurOuvre est un entier
CodeErreurRegroupe est un entier
EstMulti est un booléen
 
// Ouverture d'une archive
CodeErreurOuvre = zipOuvre("MonArchive", "\Sauvegarde.zip")
 
SI CodeErreurOuvre = 0 ALORS
// L'archive est-elle multi-parties ?
EstMulti = zipEstMulti("MonArchive")
// Regroupement de l'archive
CodeErreurRegroupe = zipRegroupe("MonArchive", "\MesArchives\ArchiveMulti.zip")
// Message d'erreur si les sous-archives n'ont pas été regroupées
SI CodeErreurRegroupe <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurRegroupe))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurOuvre))
FIN
 
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire