PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Suppression d'un fichier de l'archive selon son indice
  • Exemple 2 : Suppression d'un fichier selon son chemin mémorisé
zipSupprimeFichier (Exemple)
Exemple 1 : Suppression d'un fichier de l'archive selon son indice
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjaxCode Utilisateur (MCU) Le code suivant permet de supprimer un fichier d'une archive. Le fichier à supprimer est sélectionné dans un champ Table mémoire (TABLE_TableArchive). Attention : Pour que l'indice du champ Table mémoire corresponde à l'indice du fichier sélectionné, le champ Table mémoire ne doit pas être trié.
// Déclaration et initialisation des variables
NomRépertoire est une chaîne
NomArchive est une chaîne = "MonArchive"
CodeErreurCréation est un entier
CodeErreurAjout est un entier
CodeErreurSup est un entier
IndiceFichier est un entier
 
// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\Répertoire\Archives\ArchivePdf.zip")
 
// Création d'une archive (WINDEV Mobile)
CodeErreurCréation = zipCrée(NomArchive, "\Répertoire\Archives\ArchivePdf.zip")
 
SI CodeErreurCréation = 0 ALORS
// Sélection du répertoire
NomRépertoire = fRepSélecteur("", "", "Répertoire à ajouter")
// Ajoute la totalité des fichiers du répertoire sélectionné
// et de ses sous-répertoires dans l'archive
CodeErreurAjout = zipAjouteRépertoire(NomArchive, NomRépertoire, Vrai, zipRépertoire)
SI CodeErreurAjout = 0 ALORS
 // Sélection du fichier de l'archive
 IndiceFichier = TableSelect(TABLE_TableArchive)
 // Suppression du fichier sélectionné
 CodeErreurSup = zipSupprimeFichier(NomArchive, IndiceFichier)
SI CodeErreurSup <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurSup))
FIN
SINON
 // Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
 Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été créée
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
Exemple 2 : Suppression d'un fichier selon son chemin mémorisé
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjaxCode Utilisateur (MCU) Le code suivant permet de supprimer un fichier d'une archive. Le fichier à supprimer est sélectionné suivant son chemin mémorisé.
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
NomRépertoire est une chaîne
CodeErreurCréation est un entier
CodeErreurAjout est un entier
CodeErreurSup est un entier
 
// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\Répertoire\Archives\ArchivePdf.zip")
 
// Création d'une archive pour WINDEV Mobile
CodeErreurCréation = zipCrée(NomArchive, "\Répertoire\Archives\ArchivePdf.zip")
 
SI CodeErreurCréation = 0 ALORS
// Sélection du répertoire
NomRépertoire = fRepSélecteur("", "", "Répertoire à ajouter")
// Ajoute la totalité des fichiers du répertoire sélectionné
// et de ses sous-répertoires dans l'archive
CodeErreurAjout = zipAjouteRépertoire(NomArchive, NomRépertoire, Vrai, zipRépertoire)
SI CodeErreurAjout = 0 ALORS
// Suppression d'un fichier
CodeErreurSup = zipSupprimeFichier(NomArchive, "Répertoire\Fichier.txt")
SI CodeErreurSup <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurSup))
FIN
  SINON
// Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
Erreur(zipMsgErreur(CodeErreurAjout))
  FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été créée
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire