PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Renvoie de la liste des fichiers présents dans une archive
zipListeFichier (Exemple)
Renvoie de la liste des fichiers présents dans une archive
Le code suivant permet d'afficher la liste des fichiers d'une archive dans une table mémoire (TABLE_TableFichier).
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
NomRépertoire est une chaîne
UneListeDeFichiers est une chaîne
CodeErreurCréation est un entier
CodeErreurAjout est un entier

// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\Répertoire\Archives\ArchivePdf.zip")

// Création d'une archive (WINDEV Mobile)
// CodeErreurCréation = zipCrée(NomArchive, "\Répertoire\Archives\ArchivePdf.wdz")

SI CodeErreurCréation = 0 ALORS
// Sélection du répertoire
NomRépertoire = fRepSélecteur("", "", "Répertoire à ajouter")
// Ajoute la totalité des fichiers du répertoire sélectionné
// et de ses sous-répertoires dans l'archive
CodeErreurAjout = zipAjouteRépertoire(NomArchive, NomRépertoire, Vrai, zipRépertoire)
SI CodeErreurAjout = 0 ALORS
// Renvoie de la liste des fichiers de l'archive
UneListeDeFichiers = zipListeFichier(NomArchive)
// Affiche la liste des fichiers dans une table mémoire
  TableAjoute(TABLE_TableFichier, UneListeDeFichiers)
SINON
// Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
  Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été créée
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire