PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Modification du chemin mémorisé d'un fichier d'une archive
  • Exemple 2 : Modification du chemin mémorisé d'un fichier d'une archive
zipChangeChemin (Exemple)
Exemple 1 : Modification du chemin mémorisé d'un fichier d'une archive
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjaxCode Utilisateur (MCU) Le code suivant permet de modifier le chemin mémorisé d'un fichier d'une archive. L'archive est déjà ouverte et contient plusieurs fichiers archivés. Le chemin mémorisé des fichiers comprend uniquement le nom et l'extension du fichier. Le fichier dont le chemin doit être modifié est sélectionné dans un champ Table mémoire (TABLE_TableArchive).
Attention : Pour que l'indice du champ Table mémoire corresponde à l'indice du fichier sélectionné, le champ Table mémoire ne doit pas être trié.
// --Code de clic du bouton "Modifier le chemin d'un fichier"
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
CodeErreurChangeChemin est un entier
IndiceFichier est un entier
// Sélection du fichier de l'archive
IndiceFichier = TableSelect(TABLE_TableArchive)
 
// Modification du chemin du fichier sélectionné
CodeErreurChangeChemin = zipChangeChemin(NomArchive, IndiceFichier, "Sauvegarde.doc")
 
// Affichage du message d'erreur si la modification du chemin n'a pas été effectuée
SI CodeErreurChangeChemin <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurChangeChemin))
FIN
 
Exemple 2 : Modification du chemin mémorisé d'un fichier d'une archive
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileAjaxCode Utilisateur (MCU) Le code suivant permet de modifier le chemin mémorisé d'un fichier d'une archive. L'archive est déjà ouverte et contient plusieurs fichiers archivés. Le chemin mémorisé des fichiers comprend uniquement le nom et l'extension du fichier. Le fichier dont le chemin doit être modifié est sélectionné suivant son chemin mémorisé.
// --Code de clic du bouton "Modifier le chemin d'un fichier"
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
CodeErreurChangeChemin est un entier
 
// Modification du chemin du fichier "CompteRendu.doc"
CodeErreurChangeChemin = zipChangeChemin(NomArchive, "CompteRendu.doc", "Sauvegarde.doc")
 
// Affichage du message d'erreur si la modification du chemin n'a pas été effectuée
SI CodeErreurChangeChemin <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurChangeChemin))
FIN
 
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire