PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Affichage des fichiers en cours d'extraction
zipFichierEnCours (Exemple)
Affichage des fichiers en cours d'extraction
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)Ajax Le code suivant permet d'afficher le nom des fichiers en cours d'extraction dans la barre de message de la fenêtre.
// --Déclarations globales
GLOBAL
NomArchive est une chaîne = "MonArchive"
// --Clic sur BTN_ExtraitFichier
// Initialisation
NomRépertoire est une chaîne
FichierEnCours est une chaîne
CodeErreurCréation est un entier
CodeErreurAjout est un entier
CodeErreurExtrait est un entier
 
// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\Répertoire\Archives\ArchivePdf.zip")
 
SI CodeErreurCréation = 0 ALORS
// Sélection du répertoire
NomRépertoire = fRepSélecteur("", "", "Répertoire à ajouter")
// Ajoute la totalité des fichiers du répertoire sélectionné
// et de ses sous-répertoires dans l'archive
CodeErreurAjout = zipAjouteRépertoire(NomArchive, NomRépertoire, Vrai, zipRépertoire)
SI CodeErreurAjout = 0 ALORS
// Extraction et décompression des fichiers dans le répertoire courant
CodeErreurExtrait = zipExtraitTout(NomArchive, zipRépertoire, Aff_Jauge_Compression)
SI CodeErreurExtrait <> 0 ALORS
// Affichage du nom du fichier en cas d'erreur d'extraction
FichierEnCours = zipFichierEnCours(NomArchive)
Erreur(zipMsgErreur(CodeErreurExtrait) + " sur le fichier " + FichierEnCours)
FIN
SINON
 // Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
 Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été créée
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
 
// Procédure interne utilisée pour gérer la jauge.
PROCÉDURE INTERNE Aff_Jauge_Compression(FichierEnCours est une chaîne, Pourcentage est un entier)
SI Pourcentage < 100 ALORS
Jauge(Pourcentage, 100, FichierEnCours)
// Rafraîchissement de la fenêtre
Multitâche(-1)
SINON
// La compression est finie
Jauge()
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire