PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Recherche du type de l'archive
zipEstMulti (Exemple)
Recherche du type de l'archive
Etats et Requêtes
Le code suivant permet de connaître le type d'une archive : archive mono-partie ou multi-parties.
// Déclaration et initialisation des variables
CodeErreurCréation est un entier
CodeErreurAjout est un entier
CodeErreurDécoupe est un entier
NbPartieNécessaire est un entier
ResEstMulti est un booléen
 
// Création d'une archive
CodeErreurCréation = zipCrée("MonArchive", "C:\MesArchives\MonArchive.WDZ")
 
SI CodeErreurCréation = 0 ALORS
// Ajout de fichiers dans cette archive
CodeErreurAjout = zipAjouteRépertoire("MonArchive", ...
"C:\MonRep\MesFichiers", Vrai, zipRépertoire)
 
SI CodeErreurAjout = 0 ALORS
// Nombre de disquettes nécessaires
NbPartieNécessaire = zipNbPartieNécessaire("MonArchive", ...
1400*1024)
Info(NbPartieNécessaire + "disquettes sont nécessaires")
// Découpage de l'archive
CodeErreurDécoupe = zipDécoupe("MonArchive", ...
"A:\Archive.WDZ", 1400*1024, Faux, 100*1024)
// Affichage du message d'erreur
// si l'archive n'a pas été découpée
SI CodeErreurDécoupe <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurDécoupe))
FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été créée
Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
// Affichage du message d'erreur si les fichiers n'ont pas été ajoutés
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
 
// Archive mono-partie ou multi-parties ?
ResEstMulti = zipEstMulti(NomArchive)
 
// Affichage du résultat
SI ResEstMulti = Vrai ALORS
Info("L'archive est multi-parties")
SINON
Info("L'archive est mono-partie")
FIN
 
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire