PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Création d'une archive auto-extractible
  • Création d'une archive auto-extractible
zipCréeExe (Exemple)
Création d'une archive auto-extractible
Le code suivant permet de créer une archive auto-extractible. L'extraction des fichiers archivés s'effectue dans le répertoire courant. Le fichier "Icone.ICO" est présent sur le répertoire d'exécution de l'application.
// Déclaration et initialisation des variables
CodeErreurOuverture est un entier
CodeErreurExe est un entier
 
// Ouverture d'une archive
CodeErreurOuverture = zipOuvre("MonArchive", "C:\MesArchives\MonArchive.WDZ")
 
SI CodeErreurOuverture = 0 ALORS
// Création d'une archive auto-extractible
CodeErreurExe = zipCréeExe("MonArchive", ...
"D:\Sauvegardes\Archive.EXE", zipRepCourant, "Icone.ICO")
 
// Affichage du message d'erreur
// si l'archive auto-extractible n'a pas été créée
SI CodeErreurExe <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurExe))
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(zipMsgErreur(CodeErreurOuverture))
FIN
 
Création d'une archive auto-extractible
Le code suivant permet de créer une archive contenant un fichier, puis une archive auto-extractible.
// Déclaration et initialisation des variables
CodeErreurOuverture est un entier
CodeErreurExe est un entier
 
// Création de l'archive
nResCréation est un entier = zipCrée("MonArchive","C:\Temp\MonArchive.WDZ")
SI nResCréation = 0 ALORS
// Ajout d'un fichier dans une archive
nResAjoutFichier est un entier = zipAjouteFichier("MonArchive", ...
ComplèteRep(fRepExe) + "Test.txt", zipDisque)
FIN
 
zipFerme("MonArchive")
CodeErreurOuverture = zipOuvre("MonArchive", "C:\Temp\MonArchive.WDZ")
 
SI CodeErreurOuverture = 0 ALORS
// Création d'une archive auto-extractible
CodeErreurExe = zipCréeExe("MonArchive", "C:\Temp\Archive.EXE", ...
zipRepCourant, "Icone.ICO")
// Affichage du message d'erreur
// si l'archive auto-extractible n'a pas été créée
SI CodeErreurExe <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurExe))
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(zipMsgErreur(CodeErreurOuverture))
FIN
 
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire