DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Calcul de la taille des fichiers à extraire d'une archive
zipTaille (Exemple)
Calcul de la taille des fichiers à extraire d'une archive
WINDEVWEBDEV - Code ServeurWindowsCode Utilisateur (MCU)Ajax Le code suivant permet de vérifier que l'espace disque disponible est suffisant pour extraire tous les fichiers présents dans une archive. Pour cela, la taille non-compressée de l'ensemble des fichiers présents dans une archive est comparée à l'espace disque disponible (fDisqueInfo).
// Déclaration et initialisation des variables
NomArchive est une chaîne = "MonArchive"
CodeErreurOuvre est un entier
CodeErreurExtrait est un entier
TailleDisque est un réel
 
// Ouverture d'une archive
CodeErreurOuvre = zipOuvre(NomArchive, "C:\Répertoire\Archives\ArchivePdf.wdz")
 
SI CodeErreurOuvre = 0 ALORS
// Extraction des fichiers de l'archive
SI OuiNon("Voulez-vous extraire tous les fichiers de l'archive ?") ALORS
// Calcul de l'espace disque disponible
TailleDisque = fDisqueInfo("C:\Temp", fdEspaceLibre)
// L'espace disque est-il suffisant ?
SI TailleDisque > zipTaille(NomArchive) ALORS
// Extraction de l'ensemble des fichiers de l'archive
CodeErreurExtrait = zipExtraitTout(NomArchive, zipRépertoire)
// Message d'erreur si les fichiers n'ont pas été extraits
SI CodeErreurExtrait <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurExtrait))
FIN
SINON
// Pas assez d'espace disque disponible
Info("Pas assez de place pour extraire les fichiers")
FIN
FIN
SINON
// Affichage du message d'erreur si l'archive n'a pas été ouverte
Erreur(zipMsgErreur(CodeErreurOuvre))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire