PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Ajout d'un fichier dans une archive
  • Exemple 2 : Ajout d'un fichier dans une archive avec utilisation d'une jauge
zipAjouteFichier (Exemple)
Exemple 1 : Ajout d'un fichier dans une archive
Windows Mobile Le code suivant permet d'ajouter un fichier dans une archive. Le fichier est sélectionné par l'utilisateur grâce à la fonction fSélecteur. Le chemin complet du fichier est mémorisé dans l'archive.
// Déclaration et initialisation des variables
Nomfichier est une chaîne
NomArchive est une chaîne = "MonArchive"
CodeErreurCréation est un entier
CodeErreurAjout est un entier
 
// Création d'une archive
// Code WINDEV
CodeErreurCréation = zipCrée(NomArchive, "C:\MonRépertoire\MesArchives\ArchivePdf.wdz")
// Code WINDEV Mobile
CodeErreurCréation = zipCrée(NomArchive, "\MonRépertoire\MesArchives\ArchivePdf.zip")
// Affichage du message d'erreur si l'archive n'a pas été créée
SI CodeErreurCréation = 0 ALORS
// Sélection du fichier à ajouter
Nomfichier = fSélecteur("", "", "Fichier à ajouter", ...
  "Fichier à compacter" + TAB + "*.*", "*" , fselOuvre + fselExiste)
// Ajout du fichier sélectionné dans l'archive
CodeErreurAjout = zipAjouteFichier(NomArchive, Nomfichier, zipDisque)
// Affichage du message d'erreur si le fichier n'a pas été ajouté
SI CodeErreurAjout <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
Exemple 2 : Ajout d'un fichier dans une archive avec utilisation d'une jauge
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire