PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Ajout d'un fichier dans une archive
  • Exemple 2 : Ajout d'un fichier dans une archive avec utilisation d'une jauge
zipAjouteFichier (Exemple)
Exemple 1 : Ajout d'un fichier dans une archive
WINDEVEtats et RequêtesWindows MobileCode Utilisateur (MCU) Le code suivant permet d'ajouter un fichier dans une archive. Le fichier est sélectionné par l'utilisateur grâce à la fonction fSélecteur. Le chemin complet du fichier est mémorisé dans l'archive.
// Déclaration et initialisation des variables
Nomfichier est une chaîne
NomArchive est une chaîne = "MonArchive"
CodeErreurCréation est un entier
CodeErreurAjout est un entier
 
// Création d'une archive
// Code WINDEV
CodeErreurCréation = zipCrée(NomArchive, "C:\MonRépertoire\MesArchives\ArchivePdf.wdz")
// Code WINDEV Mobile
CodeErreurCréation = zipCrée(NomArchive, "\MonRépertoire\MesArchives\ArchivePdf.zip")
// Affichage du message d'erreur si l'archive n'a pas été créée
SI CodeErreurCréation = 0 ALORS
// Sélection du fichier à ajouter
Nomfichier = fSélecteur("", "", "Fichier à ajouter", ...
  "Fichier à compacter" + TAB + "*.*", "*" , fselOuvre + fselExiste)
// Ajout du fichier sélectionné dans l'archive
CodeErreurAjout = zipAjouteFichier(NomArchive, Nomfichier, zipDisque)
// Affichage du message d'erreur si le fichier n'a pas été ajouté
SI CodeErreurAjout <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurAjout))
FIN
SINON
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
Exemple 2 : Ajout d'un fichier dans une archive avec utilisation d'une jauge
WINDEVCode Utilisateur (MCU) Le code suivant permet d'ajouter un fichier dans une archive. Le fichier est sélectionné par l'utilisateur grâce à la fonction fSélecteur. Le nom du fichier seulement est mémorisé dans l'archive. Une jauge permet d'indiquer le pourcentage de compression. Cette jauge sera affichée dans la barre de message.
// --Code de création de la fenêtre
GLOBAL
NomArchive est une chaîne = "MonArchive"
 
// --Code de clic sur BTN_AjoutFichier
// Code d'initialisation
Nomfichier est une chaîne
CodeErreurCréation est un entier
CodeErreurAjout est un entier
NumEvénement est un entier
 
// Création d'une archive
CodeErreurCréation = zipCrée(NomArchive, "C:\MonRépertoire\MesArchives\ArchivePdf.wdz")
 
// Affichage du message d'erreur si l'archive n'a pas été créée
SI CodeErreurCréation = 0 ALORS
// Appel de l'événement
NumEvénement = Evénement("Aff_Jauge_Compression", FenEnExécution(), jaugeCompactage)
// Sélection du fichier à ajouter
Nomfichier = fSélecteur("", "", "Fichier à ajouter", ...
   "Fichier à compacter" + TAB + "*.*", "*", fselOuvre + fselExiste)
// Ajout du fichier sélectionné dans l'archive
CodeErreurAjout = zipAjouteFichier(NomArchive, Nomfichier, zipAucun)
// Affichage du message d'erreur si le fichier n'a pas été ajouté
SI CodeErreurAjout <> 0 ALORS
Erreur(zipMsgErreur(CodeErreurAjout))
FIN
// Fin de l'événement
FinEvénement(NumEvénement)
SINON
Erreur(zipMsgErreur(CodeErreurCréation))
FIN
 
// Procédure locale à la fenêtre. Cette procédure permet de gérer la jauge.
PROCÉDURE Aff_Jauge_Compression(wMessage, wParam, lParam)
SI wParam<100 ALORS
Jauge(wParam, 100, zipFichierEnCours(NomArchive))
// Rafraîchissement de la fenêtre
Multitâche(-1)
SINON
// La compression est finie
Jauge()
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire