PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Création d'une archive
  • Création d'une archive
zipCrée (Exemple)
Création d'une archive
WINDEVWEBDEV - Code ServeurEtats et RequêtesAjaxCode Utilisateur (MCU)
Le code suivant permet de créer une archive. Le nom de l'archive est saisi dans un champ de saisie : SAI_NomArchive. Le chemin du répertoire est sélectionné avec la fonction fRepSélecteur.
// Déclaration et initialisation des variables
NomArchive est une chaîne
CheminArchive est une chaîne
ResCréationArchive est un entier

// Sélection du nom de l'archive. SAI_NomArchive est un champ de saisie.
NomArchive = SAI_NomArchive

// Sélection du chemin de l'archive
CheminArchive = fRepSélecteur("", "", "Sélection du répertoire")

// Création de l'archive "NomArchive"
ResCréationArchive = zipCrée(NomArchive, ...
ComplèteRep(CheminArchive) + NomArchive)

// Affichage du message d'erreur si la création n'a pas été effectuée
SI ResCréationArchive <> 0 ALORS
Erreur(zipMsgErreur(ResCréationArchive))
FIN
Création d'une archive
Windows Mobile
Le code suivant permet de créer une archive. Le nom de l'archive est saisi dans un champ de saisie : SAI_NomArchive.
// Déclaration et initialisation des variables
NomArchive est une chaîne
CheminArchive est une chaîne = "\Sauvegardes"
ResCréationArchive est un entier

// Sélection du nom de l'archive. SAI_NomArchive est un champ de saisie.
NomArchive = SAI_NomArchive

// Création de l'archive "MonArchive"
ResCréationArchive = zipCrée(NomArchive, ...
ComplèteRep(CheminArchive) + NomArchive)

// Affichage du message d'erreur si la création n'a pas été effectuée
SI ResCréationArchive <> 0 ALORS
Erreur(zipMsgErreur(ResCréationArchive))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire