PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Recherche de factures dans un fichier XML
XMLRecherche (Exemple)
Recherche de factures dans un fichier XML
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindows MobileJavaPHPCode Utilisateur (MCU)
sMonDocXML est une chaîne = "XML"
sInfoXML est une chaîne

// Chargement du fichier XML dans une chaîne
sInfoXML = fChargeTexte(ComplèteRep(fRepExe()) + "Facture.xml")

// Initialisation des fonctions XML sur ce fichier
XMLDocument(sMonDocXML, sInfoXML)

// On se positionne sur la racine
XMLRacine(sMonDocXML)

// Lecture en recherchant les factures et les infos
// qui nous intéressent de ces factures (structure du fichier XML connue)
BOUCLE
// Recherche d'une "Facture" dans les éléments et/ou sous éléments
XMLRecherche(sMonDocXML, "FACTURE", XMLElément + XMLSousElément + XMLContinue, ...
XMLIgnoreLaCasse + XMLExact)
SI XMLTrouve(sMonDocXML) = Faux ALORS SORTIR
// On a trouvé une facture
// Informations sur la facture
XMLFils(sMonDocXML)
XMLPremier(sMonDocXML)
TANTQUE XMLEnDehors(sMonDocXML) = Faux
SELON XMLNomElément(sMonDocXML)
CAS "NUMERO"
Trace("Facture n° " + XMLDonnée(sMonDocXML))  
CAS "TOTAL"
Trace("Montant facture : " + XMLDonnée(sMonDocXML))
CAS "TVA"
Trace("TVA " + XMLDonnée(sMonDocXML))
CAS "NOTES"
Trace("Notes : " + XMLDonnée(sMonDocXML))
CAS "LIGNE_FACTURE"
// Détail des lignes de la facture en cours
// Informations sur une ligne de la facture
XMLFils(sMonDocXML)
XMLPremier(sMonDocXML)
TANTQUE XMLEnDehors(sMonDocXML) = Faux
SELON XMLNomElément(sMonDocXML)
CAS "NUMERO"
Trace("Facture n° " + XMLDonnée(sMonDocXML))
CAS "MONTANT"
Trace("Montant de la ligne : " + ...
XMLDonnée(sMonDocXML))
CAS "DESCRIPTION"
Trace("Description de la ligne : " + ...
XMLDonnée(sMonDocXML))
AUTRE CAS
// Ici on ne récupère pas les autres infos
// de la ligne, on remonte au niveau du
// détail de la facture
XMLParent(sMonDocXML)
FIN
XMLSuivant(sMonDocXML)
FIN
// On remonte au niveau du détail de la facture
XMLParent(sMonDocXML)
  AUTRE CAS
// Ici on ne récupère pas les autres infos de la facture
 FIN
 XMLSuivant(sMonDocXML)
FIN
// On remonte au niveau de la facture
XMLParent(sMonDocXML)
FIN
// Annule la recherche pour les autres éventuelles fonctions XML utilisées par la suite
XMLAnnuleRecherche(sMonDocXML)
// Libère le document XML
XMLTermine(sMonDocXML)
Info("Parcours des factures terminé")
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire