PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Récupération du contenu d'une cellule d'un fichier XLS
xlsDonnée (Exemple)
Récupération du contenu d'une cellule d'un fichier XLS
Le code suivant permet de récupérer le contenu d'une cellule d'un fichier XLS. Les lignes et les colonnes entièrement vides sont prises en compte (booléen Faux). Le fichier XLS est sélectionné avec la fonction fSélecteur.
// Déclaration des variables
ResDonnée est une chaîne
FichierXLS est une chaîne
IDFichierXLS est un entier
 
// Sélection du fichier XLS
FichierXLS = fSélecteur("", "", "Sélection d'un fichier XLS", ...
"Fichier XLS" + TAB + "*.XLS", "XLS", fselOuvre + fselExiste)
// Ouverture du fichier sélectionné
IDFichierXLS = xlsOuvre(FichierXLS)
SI IDFichierXLS <> -1 ALORS
// Récupération du contenu d'une cellule
ResDonnée = xlsDonnée(IDFichierXLS, 3, 4, Faux)
SI ResDonnée = "" ALORS
SI ErreurDétectée = Vrai ALORS
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
SINON
// La cellule est vide
Info("La cellule est vide")
FIN
SINON
// Affichage du contenu de la cellule
Info("Le contenu de la cellule est : " + ResDonnée)
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire