PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Exemple 1 : Type des données saisies dans une colonne
  • Exemple 2 : Type des données saisies dans une colonne (avec gestion des colonnes entièrement vides)
xlsTypeColonne (Exemple)
Exemple 1 : Type des données saisies dans une colonne
Le code suivant permet de connaître le type des données saisies dans une colonne d'un fichier XLS. Les colonnes entièrement vides ne sont pas prises en compte (booléen Vrai). Ce fichier est préalablement ouvert avec la fonction xlsOuvre.
// Déclaration des variables
IDFichierXLS est un entier
ResTypeColonne est un entier
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS <> -1 ALORS
// Type des données saisies dans la colonne
ResTypeColonne = xlsTypeColonne(IDFichierXLS, 3, Vrai)
// Affichage du type des données saisies dans la colonne
SELON ResTypeColonne
CAS xlsTypeChaîne : Info("La colonne est de type chaîne")
CAS xlsTypeDouble : Info("La colonne est de type numérique")
CAS xlsTypeDate : Info("La colonne est de type date")
CAS xlsTypeHeure : Info("La colonne est de type heure")
CAS xlsTypeDateHeure : Info("La colonne est de type DateHeure")
CAS xlsTypeDurée : Info("La colonne est de type Durée")
CAS xlsTypeMonétaire : Info("La colonne est de type Monétaire")
CAS xlsTypeErreur : Erreur(xlsMsgErreur(IDFichierXLS))
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
FIN
// Fermeture du fichier XLS
xlsFerme(IDFichierXLS)
Exemple 2 : Type des données saisies dans une colonne (avec gestion des colonnes entièrement vides)
Le code suivant permet de connaître le type des données saisies dans une colonne d'un fichier XLS. Les colonnes entièrement vides sont prises en compte (booléen Faux). Ce fichier est préalablement ouvert avec la fonction xlsOuvre.
// Déclaration des variables
IDFichierXLS est un entier
ResTypeColonne est un entier
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS <> -1 ALORS
// Type des données saisies dans la colonne
ResTypeColonne = xlsTypeColonne(IDFichierXLS, 3, Faux)
// Affichage du type des données saisies dans la colonne
SELON ResTypeColonne
CAS xlsTypeChaîne : Info("La colonne est de type chaîne")
CAS xlsTypeDouble : Info("La colonne est de type numérique")
CAS xlsTypeDate : Info("La colonne est de type date")
CAS xlsTypeHeure : Info("La colonne est de type heure")
CAS xlsTypeDateHeure : Info("La colonne est de type DateHeure")
CAS xlsTypeDurée : Info("La colonne est de type Durée")
CAS xlsTypeMonétaire : Info("La colonne est de type Monétaire")
CAS xlsTypeVide : Info("La colonne est entièrement vide")
CAS xlsTypeErreur : Erreur(xlsMsgErreur(IDFichierXLS))
FIN
SINON
  // Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
FIN
// Fermeture du fichier XLS
xlsFerme(IDFichierXLS)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire