PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Renvoie de la dernière erreur survenue sur un fichier XLS
  • Renvoie de la dernière erreur survenue sur un fichier XLS
xlsMsgErreur (Exemple)
Renvoie de la dernière erreur survenue sur un fichier XLS
WINDEVCode Utilisateur (MCU)
Le code suivant permet de renvoyer un message d'erreur si les fonctions xlsOuvre et xlsDonnée ont généré une erreur.
// Déclaration des variables
ResDonnée est une chaîne
IDFichierXLS est un entier
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS <> -1 ALORS
// Récupération du contenu d'une cellule
ResDonnée = xlsDonnée(IDFichierXLS, 3, 4)
SI ResDonnée = "" ALORS
SI xlsMsgErreur(IDFichierXLS) = "" ALORS
// La cellule est vide
Info("La cellule est vide")
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
// Identique à : Erreur(ErreurInfo(errMessage))
FIN
SINON
// Affichage du contenu de la cellule
Info("Le contenu de la cellule est : " + ResDonnée)
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
// Identique à : Erreur(ErreurInfo(errMessage))
FIN
Renvoie de la dernière erreur survenue sur un fichier XLS
Le code suivant permet de renvoyer un message d'erreur si les fonctions xlsOuvre et xlsDonnée ont généré une erreur.
// Déclaration des variables
ResDonnée est une chaîne
IDFichierXLS est un entier
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS <> -1 ALORS
// Récupération du contenu d'une cellule
ResDonnée = xlsDonnée(IDFichierXLS, 3, 4)
SI ResDonnée = "" ALORS
SI xlsMsgErreur(IDFichierXLS) = "" ALORS
// La cellule est vide
Info("La cellule est vide")
SINON
// Affichage du message d'erreur si la récupération n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
// Identique à : Erreur(ErreurInfo(errMessage))
FIN
SINON
// Affichage du contenu de la cellule
Info("Le contenu de la cellule est : " + ResDonnée)
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
Erreur(xlsMsgErreur(IDFichierXLS))
// Identique à : Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire