PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Nombre de colonnes d'un fichier XLS
xlsNbColonne (Exemple)
Nombre de colonnes d'un fichier XLS
Le code suivant permet d'obtenir le nombre de colonnes d'un fichier XLS. Les colonnes entièrement vides ne sont pas prises en compte (booléen Vrai). Ce fichier est préalablement ouvert avec la fonction xlsOuvre.
// Déclaration des variables
IDFichierXLS est un entier
ResNbColonnes est un entier
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS<> -1 ALORS
// Nombre de colonnes
ResNbColonnes = xlsNbColonne(IDFichierXLS, Vrai)
SI ResNbColonnes<> -1 ALORS
 SI ResNbColonnes = 0 ALORS
 // Il n'y a pas de colonnes
 Info("Le fichier XLS ne contient pas de colonnes")
 SINON
 // Affichage du nombre de colonnes
 Info("Le fichier contient : " + ResNbColonnes + ...
"colonnes")
 FIN
SINON
// Affichage du message d'erreur
Erreur(xlsMsgErreur(IDFichierXLS))
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
 Erreur(xlsMsgErreur(IDFichierXLS))
FIN
// Fermeture du fichier XLS
xlsFerme(IDFichierXLS)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire