PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Nombre de lignes d'un fichier XLS
xlsNbLigne (Exemple)
Nombre de lignes d'un fichier XLS
Le code suivant permet d'obtenir le nombre de lignes d'un fichier XLS. Les lignes entièrement vides ne sont pas prises en compte (booléen Vrai). Ce fichier est préalablement ouvert avec la fonction xlsOuvre.
// Déclaration des variables
IDFichierXLS est un entier
ResNbLignes est un entier
// Ouverture d'un fichier XLS
IDFichierXLS = xlsOuvre("C:\MesRépertoires\MesFichiers\Fichier.XLS")
SI IDFichierXLS <> -1 ALORS
// Nombre de lignes
ResNbLignes = xlsNbLigne(IDFichierXLS, Vrai)
SI ResNbLignes <> -1 ALORS
SI ResNbLignes = 0 ALORS
 // Il n'y a pas de lignes
 Info("Le fichier XLS ne contient pas de lignes")
SINON
 // Affichage du nombre de lignes
 Info("Le fichier contient : " + ResNbLignes + "lignes")
FIN
SINON
// Affichage du message d'erreur
Erreur(xlsMsgErreur(IDFichierXLS))
FIN
SINON
// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
 Erreur(xlsMsgErreur(IDFichierXLS))
FIN
// Fermeture du fichier XLS
xlsFerme(IDFichierXLS)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire