PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Démarre le service de détection des appels
telDémarreDétectionAppel (Exemple)
Exemple : Démarre le service de détection des appels
L'exemple suivant permet de démarrer un service de détection des appels.
// On démarre le service de détection des appels
SI telDémarreDétectionAppel("AppelEntrant", telOptionTypeFax, "DetectionAppel") ALORS
// Le service de détection des appels a démarré
Message("Détection des appels activés")
SINON
// Le service de détection des appels n'a pas démarré
Erreur("Impossible de démarrer la détection des appels" + RC +...
  "Détail de l'erreur :" + RC + ErreurInfo(errMessage))
FIN
PROCEDURE DetectionAppel(nIDService, nIDAppel, nStatut)
// AVERTISSEMENT :
// Les traitements réalisés dans cette procédure sont appelés à partir d'un thread
// La gestion de l'affichage doit être réalisé à partir du thread principal
// (d'où l'utilisation de PostMessage)
// Pour déboguer ce type de traitement, vous devez utiliser la fonction "Trace"
// détection des appels entrants
SELON nStatut
// Détection d'un nouvel appel :
// Note : On ne disposera de plus d'informations qu'après au moins une sonnerie
CAS telNouvelAppel :
// On signale l'arrivée d'un nouvel appel à la fenêtre principale pour ouvrir une Popup
PostMessage(Handle(FEN_Fenêtre_Appel), "AppelTel", nIDAppel, nStatut)

// On dispose d'informations sur l'appel
CAS telInformationAppel :
// On signale l'arrivée d'un nouvel appel à la fenêtre principale pour ouvrir une Popup
PostMessage(Handle(FEN_Fenêtre_Appel), "AppelTelInfo", nIDAppel, nStatut)

// La ligne a été raccrochée
CAS telLigneRaccrochée :
// On signale l'arrivée d'un nouvel appel à la fenêtre principale pour ouvrir une Popup
PostMessage(Handle(FEN_Fenêtre_Appel), "AppelTelFin" ,nIDAppel, nStatut)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire