PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Changement du curseur de la souris
  • Changement du curseur de la souris
TableInfoXY (Exemple)
Changement du curseur de la souris
Cet exemple de code permet de changer le curseur de souris lors du survol de cellules vides. Ce code est à insérer dans l'événement optionnel "Survol Souris" du champ Table.
// Déclaration des variables
MaLigne est un entier
MaColonne est une chaîne
 
// Récupération des indices de la cellule en cours de survol
MaLigne = TableInfoXY(TABLE_Table1, tiNumLigne, SourisPosX(), SourisPosY())
MaColonne = TableInfoXY(TABLE_Table1, tiNumColonne, SourisPosX(), SourisPosY())
 
SI MaLigne = -1 ALORS RETOUR
SI MaColonne = "" ALORS RETOUR
 
// Changement du curseur si la cellule est vide
SI TABLE_Table1[MaLigne][MaColonne] <> "" ALORS
MoiMême..CurseurSouris = curCroix
SINON
MoiMême..CurseurSouris = curFlèche
FIN
Changement du curseur de la souris
Cet exemple de code permet d'afficher une bulle d'aide personnalisée pour chaque cellule d'une colonne de type Image dans un champ Table.

Ce code doit être inséré dans l'événement optionnel "Survol souris" du champ Table.
nLigne est un entier
nLigne = TableInfoXY(TABLE_Table1, tiNumLigne, SourisPosX(), SourisPosY())
 
SELON nLigne
CAS 1
TABLE_Table1.COL_Colonne1..Bulle = "Bulle de l'Image 1"
CAS 2
TABLE_Table1.COL_Colonne1..Bulle = "Bulle de l'Image 2"
CAS 3
TABLE_Table1.COL_Colonne1..Bulle = "Bulle de l'Image 3"
AUTRE CAS
FIN
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire