PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Ajout d'une icône dans la barre des tâches
SysIconeAjoute (Exemple)
Ajout d'une icône dans la barre des tâches
WINDEVEtats et RequêtesCode Utilisateur (MCU) Le code suivant permet d'ajouter une icône dans la barre des tâches. Le nom du fichier icône est "C:\MesIcones\Icones.ICO". Le nom du menu contextuel est "MenuIcone". Le message de survol de l'icône est "Ventes 2001". Lors d'une opération de la souris sur l'icône, la procédure "OuvreFichier" est appelée. Si l'opération de la souris sur l'icône correspond à un double clic gauche, la procédure "OuvreFichier" ouvre le fichier "C:\MesDocuments\Ventes2001.DOC" dans Word grâce à la fonction LanceAppliAssociée.
// Initialisation de la fenêtre AjoutIcone
CONSTANT
WM_LBUTTONDBLCLK = 515
FIN
 
// Ajout d'une icône dans la barre des tâches
SysIconeAjoute("C:\MesIcones\Icones.ICO", "MenuIcone", "Ventes 2001", "OuvreFichier")
// Procédure locale OuvreFichier
PROCÉDURE OuvreFichier(MessageSouris)
// Double-clic gauche ?
SI MessageSouris = WM_LBUTTONDBLCLK ALORS
 // Ouverture du fichier "C:\MesDocuments\Ventes2001.DOC" dans Word
 LanceAppliAssociée("C:\MesDocuments\Ventes2001.DOC")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire