PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Exécuter une requête sans la nommer
  • Exemple 2 : Exécuter une requête et affecter le résultat aux champs d'une requête
  • Exemple 3 : Exécuter une requête et récupérer des informations sur cette requête
Exemple 1 : Exécuter une requête sans la nommer
Cet exemple permet d'exécuter une requête de suppression sans lui donner de nom. Cette requête ne renverra pas de résultat.
ResExec = SQLExec("DELETE CLIENT WHERE NUMCLI = " + NumClient, "REQ1")
SI ResExec = Faux ALORS
// Traite erreur
FIN
Exemple 2 : Exécuter une requête et affecter le résultat aux champs d'une requête
WINDEVWindowsLinuxJavaCode Utilisateur (MCU)Hyper File 5.5OLE DBODBC Cet exemple permet d'exécuter une requête et d'affecter les champs de la fenêtre de type Fiche avec le résultat de la requête.
// Exécution de la requête et affectation des champs
ResExec = SQLExec("SELECT NOMCLI, ADR1, ADR2, VILLE, CP FROM FACT", "REQ2")
SI ResExec = Vrai ALORS
// Transfert du résultat dans les champs associés
SQLAssocie("REQ2", NomCli, Adr[1], Adr[2], Ville, CodePostal)
// Affichage du premier
SQLPremier("REQ2")
SINON
// Traite erreur
FIN
SQLFerme("REQ2")
Exemple 3 : Exécuter une requête et récupérer des informations sur cette requête
Cet exemple permet d'obtenir des informations sur la requête exécutée.
// Exécution des champs et récupération des informations
SQLExec("SELECT* FROM FACT", "REQ1")
SQLInfoGene("REQ1")
SI ResExec = Faux ALORS
Info("Erreur exécution de la requête : " + SQL.MesErreur)
SINON
Info("Nombre de colonnes : " + SQL.NbCol)
FIN
SQLFerme("REQ1")
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire