PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Exécution d'une procédure sur un serveur SOAP
SOAPExécuteXML (Exemple)
Exécution d'une procédure sur un serveur SOAP
Le code suivant permet d'exécuter une procédure sur un serveur SOAP. Cette procédure appelée "getTemp" permet de connaître la température d'une ville identifiée par son code postal.
// Définition des variables
MessageXML est une chaîne
ResExécution est un booléen

// Définition du message XML de la procédure "getTemp" qui
// retourne la température d'une ville identifiée par son code postal
MessageXML = ...
"<SOAP-ENV:Envelope xmlns:SOAP-ENV="+ ...
"http://schemas.xmlsoap.org/soap/envelope/"+...
"xmlns:xsi=""http://www.w3.org/1999/XMLSchema-instance"""+ ...
"xmlns:xsd=""http://www.w3.org/1999/XMLSchema"">"+ ...
"SOAP-ENV:Body> "+...
"<ns1:getTemp xmlns:ns1=""urn:xmethods-Temperature"" SOAP-"+ ...
"ENV:encodingStyle=""http://schemas.xmlsoap.org/soap/encoding/"">"+ ...
"<zipcode xsi:type=""xsd:string"">94041</zipcode> "+ ...
"</ns1:getTemp> "+ ...
"</SOAP-ENV:Body> "+ ...
"</SOAP-ENV:Envelope>"

// Exécution de la procédure "getTemp"
ResExécution = SOAPExécuteXML("http://services.xmethods.net:80"+ ...
  "/soap/servlet/rpcrouter", MessageXML)

// La communication avec le serveur est-elle correcte ?
SI ResExécution = Vrai ALORS
// L'exécution de la procédure est-elle correcte ?
SI SOAPDonneRésultat(SOAPRésultat) <> "" ALORS
// Affichage du résultat retourné par la procédure
  Info("La température est de : " + SOAPDonneRésultat(SOAPRésultat))
SINON
  // Affichage de l'erreur retournée par le serveur SOAP
  Erreur(SOAPErreur(SOAPErrMessage))
FIN
SINON
  Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Exemple SOAPExécuteXML
Je n'arrive à tester l'exemple fourni, il me retourne en permanence un message me disant que "Le serveur ne répond pas ..."
Jean-François MAUPOI
12 jan. 2016