PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exécution d'une procédure sur un serveur SOAP
SOAPDonneRésultat (Exemple)
Exécution d'une procédure sur un serveur SOAP
Code Utilisateur (MCU) Le code suivant permet d'exécuter une procédure sur un serveur SOAP. Cette procédure appelée "Température" permet de connaître la température d'une ville identifiée par son code postal.
// Définition de la variable
ResExécution est un booléen

// Définition des paramètres de la procédure "Température" qui
// retourne la température d'une ville identifiée par son code postal
SOAP.Valeur[1] = 94010
SOAP.Nom[1] = "CodePostal"
SOAP.Type[1] = SOAPTypeChaîne

// Exécution de la procédure "Température"
ResExécution = SOAPExécute("http://www.Temp.com/Degré", "Température", "urn:Temp-Degré")
// La communication avec le serveur est-elle correcte ?
SI ResExécution = Vrai ALORS
// L'exécution de la procédure est-elle correcte ?
SI SOAPDonneRésultat(SOAPRésultat) <> "" ALORS
// Affichage du résultat retourné par la procédure
Info("La température est de : " + SOAPDonneRésultat(SOAPRésultat))
SINON
// Affichage de l'erreur retournée par le serveur SOAP
Erreur(SOAPErreur(SOAPErrMessage))
FIN
SINON
Erreur(ErreurInfo(errMessage))
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire